Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

DRV8825 + Nema 23 2.8A 3.6V motor @ 24V not working

Hi!
I’m in the process of building (another) CNC machine and am wanting to drive the Z-axis NEMA 23 motor with a DRV8825. I know that I won’t be able to get the full torque, but am just wanting to test/play around with the machine before i buy some TB6560s…

When i try to drive the NEMA 23, it doesn’t do a thing, it doesn’t even feel like it’s trying to put current through the coils, but i can connect a NEMA 17 and it works. I know that the motor works when connected to a different driver (one of the TB6560’s driving the X & Y axis)
Just wondering if there’s any reason why i can’t drive it??? maybe over current???
Thanks

Wiring error, motor power supply inadequate, or the current limit is not set correctly.

Hello.

If you can use the driver successfully with another motor, and you can use the motor successfully with another driver, then the problem is likely one of the issues Jim mentioned. If you are having trouble narrowing down the cause from there, please post some pictures of your setup and information about your stepper motor and power supply (like datasheets or links to where you got them). Also, can you measure the VREF voltage and share that?

- Patrick

Hi… thanks for the answers, I’ve got the motor running of a 24V 15A power supply, so should be enough current… I’ve tried all different Vref voltages, ranging from lowest to highest, and it doesn’t even feel as though the motor is getting any current supplied, it just gives the initial jolt, and then goes dead.
I’ve tried all the combinations of wiring, without result…
I got the motor from here, and am using a grbl shield on an arduino to control it, which works for nema 17…
What Vref should i be using???

Thanks

Also, when i change the micro stepping down to full step, it does get current, but just vibrates weirdly… although changing the wiring doesn’t affect it…
Could it have something to do with the overcurrent protection??? because the datasheet states that: “image
Maybe the DRV8825 just can’t drive these motors???

It sounds like you have not set the current limit properly. That is required.

If you have a genuine Pololu DRV8825 module, carefully follow the instructions on the product page, and set the current limit for 1.5 A per winding or less (not to exceed the motor current rating, of course). If you have a knockoff, the instructions probably do not apply.

sweet, i’ll give that a shot…
You say less than 1.5A per winding… does that mean for a 2.8A motor, there will be 1.4A per winding???

The motor current rating is stated per winding. The DRV8825 can deliver at most around 1.5 A per winding, without extra cooling.

To get the full torque output from that motor, buy a stepper driver capable of at least 3 A/winding.

Ahh… i get you… so i’ll need to get something like a TB6600 to get full torque…

Our High-Power Stepper Motor Driver 36v4 is capable of delivering up to 4A per phase continuously, so that could also work for getting full power from your 2.8A motor. However, please note that it is a larger form factor and the control interface for that is more complicated than for most of our other stepper motor drivers, so it probably is not practical to use with your Arduino shield. (In addition to the STEP/DIR interface, it has an SPI interface that you must use to initialize it and set the current limit on each power-up, but we have an Arduino library to help you get started with that.)

- Patrick

Yeah, I probably can’t do the initialization, as I am using GRBL to run my CNC, and that doesn’t have many spare pins/RAM… I’ve ordered the TB6600’s now, so should be able to get it up and running!!! Thanks for your help…
Also, Jim, I did change the Vref voltage to 0.75V, which should have corresponded to the 1.5A max… and it still didn’t work, so i think the drivers must be entering that overcurrent protection state the the datasheet provides, due to the 24V power supply, and the low resistance windings…

The DRV8825 carrier should be able to handle 1.5A per coil without additional cooling, so if you have the current limit set to that, I do not think that is the problem. You can generally drive stepper motors with a lower current per phase than they are rated for, which is sometimes done to save power at the cost of output torque. You could try monitoring the nFAULT pin when you test your driver to confirm whether or not the driver’s protection circuits are activating.

It sounds like you are done troubleshooting this since you likely need a more powerful motor driver anyway, but if you would like to continue investigating what is going wrong here, please post some pictures of your DRV8825 carriers and your setup.

- Patrick