Driver installation fails


i tried to install my new orangutan svp on winXP SP3. i didn’t connect it first, just installed the driver, but it says “unidentified usb hardware” (or similar - its a german version). in the device manager there is one entry at the “USB controller”-section, called “unidentified device” , and nothing at the “com & LPT”-section. i also tried to re-install the driver via the software-bundle, but no change…
when i plug in the svp, there is no further hardware installation starting…

Hello, Hahi9.

I’m sorry you are having trouble with the SVP drivers.

Is the “unidentified usb hardware” entry visible when the SVP is not connected to the computer?

To identify it, please double-click on it, go to the “Details” tab, and tell me what the Hardware Ids are. I’m not sure what they are called in German, but the Hardware Ids are the second item in the dropdown box and should look something like USB\VID_8087&PID_0020&REV_0000 but with different numbers.


there are two of them - one is only visible when the svp is connected and its hardeware Ids are

the other one is always visible
it has the Ids
(quite similar, isn´t it?)

i’m also running a orangutan X2 on the same system (this one works fine!) - is it possible, that there are som conflicts with these two devices? when i’m connecting the x2, in the device manager there is appearing “Pololu USB-to-serial adapter”, and it works fine! i’m using the same cable, so this is not the reason. i also tried different usb ports, but the svp still not recognized…

is there perhaps a certain button to be pressed before the device can be recognized??

is anybody out there, who has any idea for me?

i just finished a complete new windows installation for that reason - but no change, still the device is recognized as unidentified device on the usb port. the orangutan x2 still works fine!

when i connect the device to my mac, it is shown as Pololu Orangutan SVP, so i think it is not a hardware/cable problem.

One thing which is different from the user guide: I do not get the same installation process for the driver as shown in the guide: when i download and execute the driver driver, there is one window which shows the execution process and completion, but no warning about the not microsoft tested driver or something. (see my screenshot)


Thanks for the additional information. I would not worry about the absence of that warning message. Even if you had no drivers installed at all, Windows XP should be able to recognize the SVP and show you the names of its three USB interfaces in the Device Manager.

I don’t think there are any conflicts between the X2 and Orangutan SVP, and you don’t have to press any button to get it to be recognized.

The devices you found have a Vendor ID (VID) and Product ID (PID) of zero, which means the computer is unable to determine the USB vendor ID and product ID. This is one of the first steps the computer takes to recognize a device and it happens before the USB device drivers matter.

To get a clearer picture of what is going on, please go to your Device Manager and select View > Devices By Connection. Then please find the “unidentified usb hardware” entries and post a screenshot of them here, showing where they are in the heirarchy. Please indicate which entry disappears when you unplug the SVP.


the yellow device is disappearing during unplugging. i couldn’t find an entry “unidentified usb hardware”. this is the entry i found when sorted by view->devices by connection.

meanwhile i also tried to install on my old laptop (winXP without any servicepack). unfortunately i got other problems there so that i cannot use it, but on that system the device is recogniced as Orangutan SVP.

my WinXP SP3 installation is on a virtual disk (parallels on mac). normally all usb hardware is recognized correctly there, even my Orangutan X2. is it possible that it has something to do with that fact?

thank you for your help!

Thanks for the screenshot.

It sounds like the Orangutan SVP is recognized by two of your three machines. I have never had much luck with using USB devices from a virtual machine, so that could certainly be causing the problem.

Both the Orangutan X2 and the Orangutan SVP can be programmed directly from the latest version of Mac OS X (10.7 / Lion). Please see the “Getting Started on Mac OS X” section of the Pololu AVR Programming Quick Start Guide if you want to do that. The SVP should work fine. For the Orangutan X2, we are in the process of getting updated CP2102 drivers so that the Orangutan X2 can work on the latest version of OS X, and in the meantime I could give you instructions on how to make them work on your computer or you could continue using Parallels.


ok, that sounds nice for the future:-)
the X2 works fine on parallels, so there is no need to change anything…

but at the moment i’m just an owner of OSX 10.6. do you see either a chance to make it work on parallels as well, or is there a possibility making it work on OSX 10.6?

thanks again

I’m not sure why it isn’t working on Parallels for you, so I don’t know how feasible it would be to make it work. It would take a firmware modification to make it work on OS X 10.6, which is a lot of work.

Is there a particular reason to not upgrade to 10.7?


not really, i’m working on it at the moment;-)

Lion looks nice and my SVP-LCD says “Hello!” :slight_smile:

thanks a lot for your help!