Dreaded Winusb.dll error on Windows XP

Hi, I have a pair of Wixels I’ve used successfully on a Windows XP machine. I recently installed the Pololu software on another Windows XP machine and followed the driver install steps when I plugged it in.

But when I tried to run the configuration utility it got the dreaded winusb.dll error. I was fairly sure I followed the steps I did before. But I realized that the Wixel wasn’t in bootloader mode, and I’m wondering if that messed up the driver install.

I wet back to a restore point and tried the whole thing again, but no luck. Microsoft is not forthcoming about how to install this DLL on your own, and I found several broken links on their support site. I imagine that’s because Windows XP is now unsupported.

Do you know of a way to get this to work? This laptop only has 1.5 GB of RAM, so a Windows 7 upgrade isn’t really something I want to try.

Update: If I configure the Wixels on another machine, I can use them as a serial wireless link on the new machine. But I can’t run the config program.


The solution to this is to plug one of your Wixels into the Windows XP computer in bootloader mode, either by erasing it from the other computer or forcing it into bootloader mode with a wire as described in the Wixel user’s guide. When you see the Found New Hardware Wizard, follow the instructions from the user’s guide to get the driver for the bootloader installed. At that point, winusb.dll will be installed on your computer and you can run the Wixel Configuration Utility.

( This is not a problem for users of later versions of Windows because winusb.dll will already be installed, and this is not a problem for most Windows XP users because a new Wixel will go into bootloader mode when you first plug it into a computer. )


Thanks that did the trick.

I had stopped the app to put it into bootloader mode, but I didn’t try erasing the app. This makes sense because the wixel won’t stay in bootloader mode after power cycle unless the app is erased, not stopped.