Difficulty Installing p-load under Mac OSX 10.9.5

I just purchased a P-Star 25K50 Micro and downloaded the User Guide (pololu.com/docs/0J62). When I get to the “Getting Started” section under “5.1. Installing p-load and drivers” for “Mac OS X”, I followed the directions …
“If you are using Mac OS X, you should download the Pololu USB Bootloader Utility (p-load) for Mac OS X [pololu.com/file/download/p-load-1.0.0.dmg?file_id=0J802] (33k dmg). Double click on the dmg file to open it, and then follow the instructions in README.txt to install the utility.”

After opening the “dmg” file to mount the virtual disk as a “p-load” window, the “README.txt” file it says …
"To install, drag “p-load” to “usrlocalbin”."
I click on the “p-load” file and drag it over the “usrlocalbin” file in the “p-load” window and nothing happens. Normally, I believe this should copy the “p-load” file to the referenced directory.

Opening “Terminal” on my Mac, I cannot find the “use/local/bin” directory that the “ReadME.txt” file says is the install location. I have limited experience with Unix - especially on a Mac.

I need some help getting “p-load” installed. Does anyone have any ideas?

Thanks, CJr

Hello, CJr.

It looks like you might have a typo when searching for the file. It should be “/usr/local/bin” not “use/local/bin”. If you search in that location, can you find the file?

- Grant

Thanks Grant,

Ooops, I saw the typo as well. It happened when I retyped the directory in the message. This is what I typed into the MAC OSX Terminal and the response the Unix Terminal returned…

Last login: Tue Mar 10 15:15:14 on console
Mac-mini:~ Admin$ pwd
/Volumes/Macintosh HD/Users/Admin
Mac-mini:~ Admin$ cd usr/local/bin
-bash: cd: usr/local/bin: No such file or directory
Mac-mini:~ Admin$

My Mac-mini cannot find the “use/local/bin” directory.

I am also puzzled as to why dragging and dropping “P-load” file to the alias as directed by the the Pololu installation instructions doesn’t work. I can send screen images if that would help. Do you have access to a Mac to try the installation?

Thanks for your help, CJr

Could you try “cd /usr/local/bin” (the leading slash matters)?

- Grant


I went to “Terminal” and tried it with a leading “/” Still no joy…

Last login: Tue Mar 10 17:51:27 on ttys000
Mac-mini:~ Admin$ cd /usr/local/bin
-bash: cd: /usr/local/bin: No such file or directory
Mac-mini:~ Admin$

Anything else I should try?

Again, thanks for your assistance in this,


It looks like you don’t have a “/usr/local/bin” folder. To help us better understand how your system is set up, could you run the following commands?

printenv PATH ls /usr ls /usr/local

- Grant


Using Terminal, I executed the three commands with the following results.

Mac-mini:~ Admin$ printenv PATH
Mac-mini:~ Admin$ ls /usr
X11 bin libexec share
X11R6 lib sbin standalone
Mac-mini:~ Admin$ ls /usr/local
ls: /usr/local: No such file or directory
Mac-mini:~ Admin$

Is this any help? CJr

It sounds like you do not have the “/usr/local/bin” directory. You should be able to make the directory using the following command:

After you make the directory, could you retry the P-Star installation instructions?

- Grant