Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

D36V6F12 does not work with capacitor

We are using D36V6F12 regulator extensively with 24-26V battery source. As suggested on the website, we always add 33uF 50V capacitor to the input. Yesterday we’ve changed the usual 1.5m supply cable to about 30cm wire of the same 18AWG. The regulator quickly overheated and the load (TFT display) did not work at all, despite having 11.5V on output and drawing about 300mA.

What is extremely weird, is that input current was about 500mA at 26V. After checking and re-checking everything and trying two more regulators (new, out of the box), we finally tried it without the capacitor. Everything worked perfectly right away. Without the capacitor the regulator draws about 120mA and stays barely warm.

We tried another capacitor from different supplier and the result is the same - overheating and load does not work. The only difference with our regular setup is the new wire is shorter and has a connector in the middle. I can only think about hitting some weird resonance with regulator noise on the input.

Any suggestions?

Hello.

That behavior seems very strange. Can you post some pictures of your setup, including pictures that show how you had the electrolytic capacitor connected?

- Patrick

Found a problem, and it is truly ridiculous. The low quality power&video cable had a short between + and video conductors. It is amazing that Pololu managed to put out 11.5V anyway before tapping out at about 800mA. Had nothing to do with capacitor after all.

I guess this topic can be deleted now. I don’t have permission to do so.