D24V10F12 won't power 200ma but S18V20F12 works

I am using a 4S lipoly pack (16.8V) to power a multirotor used for FPV. The video transmitter is 12V only and the camera is 5V. From the main battery I run to the D24V10F12 (12V 1A step down) which then feeds both the video transmitter and also feeds a D24V6F5 (5V 600ma step down) which feeds the camera.

When I plug in the battery I get little to no voltage output. Its as if the regulator isn’t coming online. If I disconnect the camera then it will power up the VTX and then I can plug the camera in and it will continue to work. It will just not bring it all up initially. The VTX and Camera draw close to 200ma. Also if I put a LC filter in between the 12V regulator and VTX then it also will not power up the VTX (even with camera disconnected).

Now if I swap that with the larger S18V20F12 then there is no problems. Everything comes right up.

On the VTX I do have two 220uf 16V caps. One on the 12v coming in and one on the 5V exiting the D24V6F5 stepdown going to the camera. I am not sure if these caps are causing too high of a inrush surge. They are soldered and hot glued so they are not easily removable at this point.

Any ideas? Thanks!


I suspect that when the camera is in the system, the D24V10F12 step-down regulator’s short-circuit/over-current protection is being triggered during start-up. You might try limiting the inrush current by adding a resistor in series with your camera (maybe something like 1Ω). If you post a diagram and pictures of your setup, I might be able to give additional suggestions.

- Jeremy

Wiring is as follows:
3S lipo > D24V10F12 > videotx and D24V6F5 > camerao and OSD.

ON the output of the 12v regulator I had a 220uf cap. On the output of the 5V regulator I had a 220uf cap.

I had a chance to experiment today and once I took the 220uf cap off the 5V regulator everything powered up properly.

I assume between the two capacitors the inrush was too much. Taking the cap off the 12V one made no difference though. I put a 1uf (only other cap I had at the moment) in place of the 220uf on the 5V reg and everything still worked. Trying to keep things smooth to filter out any motor noise from the camera system.

I am glad you got it working. Thanks for letting us know.

- Jeremy