D15V35F5S3 shuts downs for unknown reason


I build two-wheeled robot from the following components:
Tamiya gear box 70097
Step-Down Voltage Regulator D15V35F5S3
DRV8833 Dual Motor Driver
6x1.25V NiMh accs

Mabuchi motor FA130 eat 2.1A in stall. DRV8833 tolerate 2A in peak per channel.
At last, the voltage regulator can handle 4.5A in peak.
So, I don’t see any problems in my calculations.

But, when I try to drive two wheels simultaneously with PWM (30-50%), I have got shut down of voltage regulator - it just set zero voltage on output. And I don’t understand for what reasons :frowning:

One wheel driving works well. I also tried to power DRV8833 directly from accs, and it works well too. But 7.2V is not good for 3V Mabuchi, so I need a voltage regulator.

Please, give any advices why the voltage regulator shuts down? And how to workaround it?


It sounds like the voltage regulator is shutting down due to over current. Could you tell me whether you have the regulator set to output 3.3V or 5V? Also, could you send a picture that clearly shows the connections in your setup?

  • Grant

Actually, I use two D15V35F5S3. One for Raspberry Pi and one for motors.
And, I tried to switch D15V35F5S3 to 3.3 mode - no change.

Here is the diagram.


I think your current is just spiking above the over-current threshold of the regulator and causing it to shut down. One way to avoid this is to limit the motor acceleration by ramping up the speed gradually. However, I think the best approach would be to supply the motors with 3.3V instead of 5V (those motors are intended for 3V operation). If you switch the regulator to output 3.3V, does the problem go away?

- Ben

I wrote, 3.3V mode doesn’t help. I’m also think that current spike is probably reason of this behavior. But, regulator can tolerate up to 4.5A and two motors can take only 4.4A in stall.

Another thing that might be causing the issue is motor noise. You might try soldering some 0.1 uF capacitors to the motor leads as described in this application note. If that does not help, you might try swapping out your power supply for a battery, or using a lower current, higher voltage motor like this motor, which can be directly substituted for the motors that were included in your Twin-Motor Gearbox.

  • Grant

I tried to attach 0.1uf capacitors to the motors - no results. Low power supply also is not good, because I power Raspberry PI and the motors from the same source.
But, I solved the problem! There is current threshold resistor on 11pin of TPS53114. By default, it has a value of 7.5K. So, I soldered another 6.8k resistor in parallel and got 3.5k in summary. No more shutdowns.

Also, I have cheap china UBEC for RC ($5). This device can stand up to 5A in peak. And it’s really can do it without any kind of magic, instead of D15V35F5S3.

Thanks for keeping us updated and letting us know how you resolved your problem.

  • Grant