D15V35F5S3 always has output


I am inputting 7.2V into my D15V35F5S3 and am always seeing output (5V). I had thought that if the en pin is not wired up then it would not output anything. I have also tried wiring the en pin to ground but it still outputs. I tried measuring the en pin voltage to see if it might be above the threshold for enable but it doesn’t seem to be (fluctuating low millivolts), so I don’t appear to have accidentally soldered it to Vin. Does anyone know what might be happening?



The regulator should be enabled when you do not connect anything to the board’s enable pin. Here is what the product page says:

It sounds like your enable pin is either not connected to the chip or your ground connection is not connected to the board well. Can you check a couple of things? Can you check that there is no stray solder connection between the VIN pads and the enable pad? Also, can you check that your connection/solder joint to the enable pin is solid? Finally, with power completely disconnected, can you check that there is continuity between the pins I have indicated in the image below? The enable pin on the chip is the pin second pin in from the edge on the side indicated by the red line.

- Ryan

Thanks Ryan,

You were right, it was a bad connection between the header pin and the en pad. There was continuity between the en pad and the chip pin but not between the header pin and chip pin. I fixed that up and now bringing the en pin to ground stops the output. Much appreciated.