Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Controlling two Stepper Motors with two ICs and one Raspberry Pi 3B+


#1

So I have two DRV8825 and two Nema 17 (Manufacturer Part Number: 17HS19-2004S1). They’re wired as follows:

I’ve tested both motors and drivers and they both seem to work normally. But for some reason I am measuring 0V when I connect the negative pole of my multimeter to the ground rail and the positive pole to the potentiometer on the second DRV8825. At the same time the first DRV8825 is doing fine.

My question is as follows: Is it possible to run two steppers with two DRV8825 that are connected in parallel with one Raspberry Pi?

And if not can anybody suggest another solution, e.g. a driver that could control both steppers simultaneously?


#2

Hello.

In general, you might consider using the Raspberry Pi’s hardware PWM GPIO pins to provide more precise timing control for toggling the STEP pin on the driver, but the connections in that schematic should be OK for basic functionality and should allow you to set VREF.

Can you post pictures here that show your connections including any soldered connections you made? What kind of 12V supply are you using?

-Nathan


#3

I’m using a 12V/4A power supply. But I also tried to power each stepper with an own power supply. Both times VREF on the second driver was 0V.


#5

I tried measuring Voltage between RST and GND… On the first driver the multimeter shows 3.3V as expected. But on the second driver the voltage is constantly changing.
Could this be the reason why I cannot set VREF on the second drive? And if so, how do I fix this?


#6

From your pictures, it appears that you are using knockoffs of our DRV8825 carrier boards, but I cannot see them very clearly to tell for sure. Also, I cannot see your soldered connections on the drivers to tell if those seem like they should work OK, but it appears you are making the connections shown in your schematic diagram. In general, solderless breadboards do not always make good connections, so you might use a multimeter to verify the supply voltage at the driver board.

If you are using our boards and want to continue troubleshooting, please post pictures that show the pin soldering so we can see if those look OK.

-Nathan


#7

Everything is working now… I’m not sure what exactly was the problem but it seems to be because of the breadboard or one of the cable I’ve used.

Thanks for your help,
E. Paul