Connectivity Issue with Sharp GP2Y0D810Z0F Digital Distance

I purchased 5 of the Sharp GP2Y0D810Z0f Digital Distance Sensor (10cm) a while ago. I’m just getting around to opening them to use for a project. So I wanted to test the input change when an object comes into its range.
As far as code, I loaded the Example-Digital-StateInputChange example. But I did not get that far to test with code.
The issue I’m seeing is that when I connect the sensor to the Arduino UNO board.
Vin - to 3.3 volts (I also tried 5volts) from Arduino. Then I tried a separate 5v source connect ground to Arduino also.
Gnd - to ground on Arduino
Out- This was going to GPIO 2 on Arduino UNO.

When I started I connected ground first, loaded code into Arduino. After upload was done, I then I tried to connect Vin to 3.3. When I did that the lights on the Arduino dimmed, so i pulled the connection to Vin from the Arduino.

I tried the same sequence over again, this time with 5V on Arduino. I got the same results.

I tried this again with a Pro Trinket. I got the same results.

I opened up my 2nd of five sensors. I went through the same sequence on the 2nd sensor and yielded the same results.

I’m baffled. The connectivity appears straight forward.

As far as power to the Arduino, I first used USB power from my MacPro laptop, I then switched to a 9V input adapter to the Arduino and stilled yield the same results from above.

After speaking with the support person (I apologize, I forgot your name) I was instructed to try a couple things.

  1. I placed a separate power source of 3.7V to Vin and Gnd of the sensor, and there was no light.
  2. I tested Vin and Gnd with a multimeter (set to ohms) and it showed a short.

I performed this with 3 of the 5 sensors I have.
Are there any other ideas?

Another update, the last 2 of 5 shows good with separate power and with the led light on once i wave my hand across.
i connected the last two to the Arduino 5V and it worked fine.
So 2 of the 5 check out good.


It is possible that when soldering the headers, you bridged the VIN and GND pads. Could you post pictures of both sides of the problematic sensors?

I also noticed that you mentioned powering the Arduino with a 9V adapter and at another point in your original post it sounded like you might have tried powering the sensors from the Arduino’s VIN pin. Please note that these sensors have a maximum operating voltage of 6.2V, so if you applied more than that at any time, it could have damaged the sensors in some way.


No, the soldering job is clean. That’s the very first thing I check before connecting to the board. Plus there’s ample spacing for the soldered connections.
No, I used the Vin only when I had the USB as the power source. When I connected the 9V to the Arduino, I used the 5V and 3.3V.
I definitely read the specifications prior to purchasing to insure what the voltage requirements were.

We test every board and have had no other reports of issues like this that would indicate some kind of systematic or batch-level defect, so your having trouble with 3 of 5 units strongly indicates a problem with your setup. Could you post the pictures that I requested previously?


I’m flying home tomorrow morning on business. I’ll be able to provide it then.

I found out Sunday what the root cause of the problem is. I had the same problem with a mosfet I setup on Sunday.
Apparently, the two columns of the breadboard I was using to connect the sensors had a short. I changed everything else except the breadboard connections. The same thing happen to a mosfet I connected and when I moved the connections from the same column it worked.
So mark it up as user error (user’s breadboard). When I removed the tape from the bottom two of the connectors were fused together.

I am glad you found out the cause of the problem. Thank you for keeping us updated.


No problem.
Thanks for the help.