Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Comport windows 10 "issue"

Hi,
I have the 391 usb to comport unit connected to a windows 10 platform. I can not install the driver correctly (using the “pololu-cp2102-setup-x64.exe”) as the I get this message: " The current language is not supported by the device driver installation wizard. Contact the vendor that provided you this package." If I place windows in “testsigning” (from a prompt: bcdedit -set testsigning on) mode then I can install the comport in the old way, but as soon as a change to normal mode the comport is not available and has the “!” appears in the device manager window. hope for a quick fix, thanks
/Gorm

Hi,
found a way to upload the windows respond see below:

/Gorm

Hi,
I found a way to solve it. I press and hold the shift key down during restart and selecting “Troubleshoot”, “Advanced options”, “Startup Settings” and select “disable driver enforcement signature” it then let me install the driver using the “pololu-cp2102-setup-x64.exe”. Then I restarted the system and it work fine now.
/Gorm

Hello, Gorm.

I am sorry you had trouble installing our CP2102 drivers. Thank you for posting the solution you found.

According to an article from Silicon Labs, this issue is caused by a missing language code in dpinst.xml. That article describes how you might be able to modify dpinst.xml to include the correct language code for your computer.

For Windows 8 and later, a simpler solution would be to right-click on each of the two INF files (slabvcp.inf and plluvcp.inf) and select “Install”. This would directly install the drivers, bypassing the Device Driver Installation Wizard.

–David

Hello David,

Thanks for you respond. Regarding the language code, I am using the
english version of windows 10 so… I guess if somebody has the time
they might look in to this. BTW if the language code issue which I find
hard to believe as I run the system in english; why does it work not?
just a mind teaser :-).

/Gorm

Den 17-04-2017 kl. 20:36 skrev DavidEGrayson:

I tried to reproduce the issue here, on a Windows 10 computer using English, and was unable to. Are you still able to reproduce the problem on your computer? Do you still get that error message if you try to run the installer executable?

–David

Hello David,

It was a newly installed windows 10 and I can not “go back” and try to
reinstall the driver as the system is in production now.

/Gorm

It will be hard to troubleshoot this error if neither of us can reproduce it. If the issue happens to you again and you would like help troubleshooting, please let me know.

–David

sorry, i would like know if someone found the solution, i get the same problem

Hello, CGJ.

We have not found a solution to this problem.

For Windows 8 and later, a simple workaround would be to right-click on each of the two INF files (slabvcp.inf and plluvcp.inf) and select “Install”. This should install the drivers, meaning you do not have to run pololu-cp2102-setup-x64.exe or pololu-cp2102-setup-x86.exe.

If that does not help, can you tell me what version of Windows you are using and what CP2102 Pololu products you are trying to use?

–David

1 Like

I have done that, in mission planner when I try to conncet I can’t. It would be for the drivers or it’s a different cause?

We did not make the software you are using and are not familiar with it. You might try contacting the developer of the software for help troubleshooting that error message.

–David