Com Port Issue ~ A-Star 32U4

Hello, my robot is the Pololu 3pi+ 32U4 Turtle Edition. I downloaded the Arduino IDE and installed the appropriate board/packages listed in the User Guide. However, I am receiving the following issue regarding my ports:

avrdude: ser_open(): can't open device "\\.\COM4": The system cannot find the file specified.

Failed uploading: uploading error: exit status 1

I have followed every direction appropriate for Windows 11. Please help ASAP. Thank you!

What version of the Arduino IDE are you using? If it’s 2.0.0 or greater, can you try expanding the port drop-down and clicking the “Select other board and port…”, then verifying that the Pololu A-Star 32U4 is selected as the board and that the port matches the port showing up in your Device Manager? After confirming that they match, please click the “OK” button to re-select them and try again. If that does not work, could you try completely shutting down your PC, disconnecting the 3pi+, re-booting your PC, then plugging the 3pi+ back in and trying again?

If you still have problems after trying those suggestions, could you enable verbose output from the “Preferences” menu in your Arduino IDE and then post the full error message you receive when you try to compile an example from our library? Also, could you post a picture of your Device Manager showing the entry for the 3pi+?


Thank you for reaching out. I am using the 2.3.2 version of the Arduino IDE.

I have tried your suggestions multiple times, but it is still not working. I selected the correct board and the port matches the Pololu A-Star 32U4 (COM 4).

I have attached a screenshot of my device manager matching with the appropriate board and port, along with the full error message.

You mentioned installing the boards package, but did you also following the instructions in the “Installing Windows drivers” section of the 3pi+ 32U4 user’s guide?

It looks like your Device Manager is indicating an issue. Could you go to the “properties” of the Pololu A-Star 32U4 entry (right-click on it and choose “Properties”) and post a screenshot of the “General” tab?


Yes, I installed the appropriate Windows drivers mentioned in the guide.

There is a “Code 10” error listed in the screenshot.

Thank you for the additional information. Some USB cables are only intended for charging and not data communication, which can cause that kind of error. Could you try some different USB cables (preferably ones you can verify work for data transfer with another device)?

By the way, I’m not sure why you see both the 3pi+'s regular USB port and the bootloader port at the same time. Did you ever try using the “Add Legacy Hardware” option in the Device Manager in an attempt to get the board to be recognized? This option is only for older devices that do not support Plug and Play and could cause some problems. So, if you did try doing that, could you follow the instructions David’s post here to remove those non-working entries and see if it helps? That post is about the Maestro, but it should be the same process for an A-Star.


I have tried multiple USB cables that are meant for data transfer/communication. Whenever I plugged the USB cable, it wasn’t detected by the device manager, so I had to use the “Add Legacy Hardware” option. I went through David’s post and removed the non-working entries, but it doesn’t help at all. I believe the issue here is the port/cable not being detected.

Based on this guide, what does it mean by plugging in an A star. Additionally, how do I make this board recognized without having to use the “Add Legacy Hardware” option?

The 3pi+ 32U4 is part of our 32U4 family of boards, and it has a lot in common with our A-Star 32U4 programmable controllers, so some parts of the documentation that apply to multiple devices refer to them all as A-Stars. So when the guide talks about plugging in the A-Star, it would just mean plugging in the 3pi+ in your case.

If possible, could you check if the 3pi+ is still not recognized if you use a different USB port or a different computer? Are you able to use the same cable and port to successfully connect to another device?

Did this 3pi+ ever work for you through USB? Was it purchased as an assembled version or a kit? Some close-up pictures of the robot’s circuit board might help us check for any visible problems.


I have already tried a different device and a different USB cable. However, I am still receiving the same error.

I ordered the robot pre-assembled, and nothing else came along with the robot. Whenevr I connect any USB Cable with the robot to any device, the robot automatically turns on. However, based on the screenshots of my Device Manager I have posted above, there is a little yellow triangle on the board. I believe the issue here is the device not being able to recognize the cable.

It sounds like there could be a problem with the robot’s USB connectivity, but to rule out an issue with your computer or cable, can you confirm that they allow you to connect to a different USB peripheral (such as another microcontroller board)? If so, could you please email us with your order information and a reference to this thread?