Charging a Zumo with an iMax B6AC v2 charger


I bought a Zumo robot for Arduino and the iMax B6AC v2 charger, and I was trying to charge the batteries inside the robot directly as said in the manual.
I actually did it similar as in these posts: connecting the bananas to the charger, then the T plug with the JST connector, and finally to the charging port of the Zumo shield (with the red cable to the + connector). Then I chose NiMH charge and set the current to 2A or lower (my batteries are 1.2V and 2.000 mAh). However, when I long press Start it shows the charging screen for around 10 seconds and then it appears an error saying “CONNECT ERROR CHECK MAIN PORT”.

How can I fix it?
I tried with the robot OFF and also ON, and I even tried the discharge option of the charger but it gives a connection error also…


If you have a multimeter, you might try checking continuity to make sure the connector is making good connections to the Zumo battery pins. Could you also post a picture showing how you have everything connected?

- Grant

I don’t have a multimeter right now… but I could try with another Zumo robot (we bought 3).
It seems a connection issue because the first time you try the error takes 10 seconds to appear and the charger screen shows 0V, the second time it shows around 20V and stops in 1 or 2 seconds, like if the circuit was open somewhere and when trying to charge it was creating a 20V difference between + and -, could be?

Here you have a picture of how is everything connected.


In your picture, it looks like you are trying to use the JST RCY connector. That connector was meant to fit the corresponding JST RCY connector and not our 0.1" female headers. You might try using the Futaba connector to charge your Zumo. It might take some effort to get it all the way down onto the headers. If you have some jumper wires, it might be easier to use those with the Futaba connector. Alternatively, you could use the alligator clips with some wires or male headers.

By the way, we recommend charging the Zumo with the power turned off.

- Grant

It was this! I tried with the Futaba connector (had to cut the cover a bit in order to make it go through until the bottom) and now it’s working!

Thanks a lot! :slight_smile: