Can't seem to install SVP drivers

Really don’t understand here… I’m trying to install the SVP drivers, everything’s in place and should work fine, but for some reason windows won’t install the drivers!

I tried to install them manually, going through device manager and finding the proper driver (whether I chose “have disk” or find the device in the list doesn’t work), but still no luck. The same happens for all 3 devices listed int he manager; SVP Programmer, SVP TTL Serial Port and SVP USB Communication Port.

Few screenshots attached:

Any idea what is going on here?

I already have Atmel Studio 6 installed, and the pololu AVR library…



I am sorry you are having trouble installing the Orangutan SVP drivers. What version of Windows do you have? Please try downloading the drivers from the “Installing Windows Drivers” section of the Orangutan SVP user’s guide. After you run the installer, be sure to unplug the SVP and plug it back in.

For Windows XP/Vista/7, the only driver needed for the Orangutan SVP is the file pololu_usb_to_serial.inf, which should get installed on your computer by the installer. I’m not sure why you would be getting an error about a file not being found.

Have you successfully used other devices that create virtual COM ports before? Which ones?


pololu_usb_to_serial.inf is the one I’m trying to install.

I have successfully installed the maestro drivers & application, and the virtual COM port works for the maestro, so I really don’t understand why it doesn’t work this time. What is also weird is that the driver got installed - it is in the windows driver list.


I know something else you can try, but first I need to know: what files do you see in “C:\Program Files (x86)\Pololu\Orangutan SVP” and what files do you see in “C:\Program Files\Pololu\Orangutan SVP”?


It would seem as my laptop is actually the problem… Now a few other drivers are giving me problem. Sounds like a re-install to me.

I installed the whole thing (AVR Studio 6, pololu library & drivers) on my workstation without a single hitch, as expected. I’m sure there would be a way to force the install on the laptop somehow, but with other problems arising with it I think best is just to start fresh hoping it’s not deeper hardware failure…

I’ve never had a problem with any of the pololu hardware and software, and I can’t say the same for that laptop - simplest explanation most often the right one, right :wink:

Thanks again for your help,