Cant run the make_all file

I followed the steps from section 10.c in the Pololu Wixel User’s Guide. However when I try to run the make_all file I the following error message appears:
make: *** [libraries/src/uart/uart0.rel] Error 1

Please help!


Could you post the entire build output from when you try to run make_all?

- Jeremy

Hi Jeremy!
The output looks like on the attached image if I try to run make_all from the wixel-sdk folder.

It does not look like you have the SDCC installed. Could you verify this by running “sdcc” in the command prompt?

You should try downloading and installing the Wixel Development Bundle, which includes the SDCC. You can find it in the “Resources” tab on the product page:

- Jeremy

I have downloaded and installed the bundle files (since before). I tried to un- and reinstall SDCC, but it still didn’t work. I tried to start SDCC from cmd by typing “start scdd” and “start sdcc.exe”. Not sure if that’s the way to do it. It returned a message saying it couldn’t find the file. Below is a picture of the sdcc-folder. I also ran make-v to check the GNU build utilities and they were ok. I tried turning off my anti virus program but it didn’t help.

Could you try typing “sdcc” in the command prompt with nothing else?

- Jeremy

Looks like this

Also checked the path: C:\Program Files (x86)\Pololu\Wixel\bin;C:\Program Files\SDCC\bin

It looks like the SDCC is in a folder called “Program” and not “Program Files” or “Program Files (x86)”. Make sure your PATH includes the correct location: C:\Program\SDCC\bin