Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Can't program 3pi


#1

Hi,

I have been programming my 3pi for about 2 weeks now, and all was well.

This morning it failed.
I can still connect my 3Pi though the pololu PGM03A programmer and read the voltage OK and the Device Signature.
But when I click Program it starts the process and erases the memory but then when it gets to the program part it fails.

I get this error:

An error occured while executing command with ID 0x14. Timed out waiting for a response. Protocol state at time of timeout was 'Get Data’
Timestamp: 2013-11-06 09:32:16.350
Severity: ERROR
ComponentId: 20100
StatusCode: 1
ModuleName: TCF command: Modules:writeToMemory failed.

An error occured while executing command with ID 0x14. Timed out waiting for a response. Protocol state at time of timeout was ‘Get Data’.

I have removed and replugged in the programmer. Turned the 3Pi off and on again. changed the COM port from 4 to 5 in device manager.
removed all tools from Amtel Studio and re added the com ports. Non of this made a difference.

any ideas ?

Thanks very much
Dave


#2

Further to this. sometimes I get this warning.

Read voltage 0.0V is outside selected device’s operating range: 1.8V to 5.5V
Do you want to continue?

but other times it tells me the Target voltage (when I click on Read) is 4.9V


#3

Hello, Dave.

Since you are sometimes getting a message that indicates your battery voltage is too low, could you try programming it with freshly charged batteries? Could you also try this workaround that Jeremy suggests for a bug with Atmel Studio that you might be encountering when programming.

- Grant


#4

Thanks Grant.

I will give new batteries a go.

I use that methed to program my 3pi all the time anyway.


#5

I tried a new programmer from a friend and it works…
seems mine is dodgy.


#6

I am glad you were able to program your 3pi. What programmer does your friend have? Could your friend try using your programmer to program his device to see if it works?

- Grant


#7

Hi,

I have fixed my programmer and thought I’d post how in case it helps anyone else.

It seems that the firmware on the programmer had been corrupted somehow.
It is possible to flash and update the firmware and instructions are contained in the manual below, I go this link from the company that sold me the programmer.
http://www.hobbytronics.co.uk/datasheets/pololu_usb_avr_programmer.pdf

It was easy to do and it sorted my problem

Dave


#8

Thanks for letting us know how you solved the problem. By the way, the PDF you linked to is an older version of the user’s guide that only covers up to firmware version 1.01. You can find the most up-to-date version of the user’s guide here .

- Grant