Can't make wireless_adc_tx

I’ve successfully run a make_all.bat, it appears the wireless_adc_tx was missed/excluded from the apps list (in the apps folder of the sdk).
I’ve also tried to run make appName and which returns the message “Nothing to be done for C:\wixel-sdk\apps\wireless_adc_tx\wireless_adc_tx.c”

Don’t quite understand what’s going on, so could you pls enlighten me?



I am sorry you are having trouble with the Wixel SDK. What makes you think the app was not compiled? What happens when you run “make wireless_adc_tx”? What files do you see in the apps/wireless_adc_tx directory after running that? What version of the Wixel SDK do you have and where did you get it from?


Hi David

Version 3, released 2012-01-17 of the Pololu GNU Build.
I think I may have got the sdk from Sourceforge.
Files in the app\wireless_adc_tx are: and wireless_adc_tx.c
When I run make on wireless_adc_tx the message received was 'Nothing to be done for wireless_adc_tx
Doing a make_all ran ok for the rest of the apps ie, created the adb, asm, wxl files etc.

Anyway, I’ll uninstall and re-install from scratch and get the sdk from your site.


The Wixel SDK is available as part of the Wixel Development Bundle, which you probably downloaded. The Pololu GNU Build Utilities are separate from the Wixel SDK but they are both included in the bundle. We do not distribute the SDK on SourceForge.

The version of the Wixel SDK in the bundle will be as old as the bundle is. You can get the latest version by downloading it from github: with the “Download Zip” button, or if you are git user then you can get it using a git clone operation. Could you try downloading the SDK from github and see if you still have the same problem?


I started over again and downloaded the bundle for your site - everything is working fine!

Thank you.