Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Can't get wixel into bootloader mode


#1

Hi!

I loaded a malfunctioning app into the wixel, and now the wixel doesn’t automatically shows up in the Wixel configuration utility. So, I disconnect all modules, power supply and the USB cable, and put a wire between P2_2 to 3V3. I connect the wixel via USB, and the yellow LED turns on. The wixel configuration utility still can’t see the wixel. I disconnect the wire between P2_2 and 3V3 (still having the USB connected to my PC), and the yellow LED’s strength is reduced by 99 %. I can still see it glowing a tiny bit, but nothing like when it is solid.

What is wrong and how can I get the wixel into bootloader mode?


#2

Hi.

From your description it sounds like the Wixel did not successfully get into bootloader mode. If you have not already, could you try the procedure a couple more times making sure that your wire between P2_2 and 3V3 is making good connection with both pins before plugging in the USB? In our experience it can take a few tries.

Are you using the same USB cable and port that you used when initially programming the Wixel? Did you do anything with the Wixel between loading the malfunctioning program and trying to get it in bootloader mode?

-Claire


#3

I know that the P2_2 and 3V3 is connected, because of the yellow LED turns on and stays solid when I have the wire between the two contacts. I have tested multiple times with the exact same outcome. It’s the same USB port as before and I have another wixel that works correctly using the same USB port. Do you know why the yellow LED is dimmed down with 95 % when the wire between P2_2 and 3V3 is removed? Is it supposed to do that?


#4

All the pins of the CC2511F32 on the Wixel are pulled high by default, which could cause the yellow LED to light dimly. Could you measure the reset pin on your Wixel with USB connected but nothing else? Also could you post pictures of both sides of the Wixel and a copy of the malfunctioning app’s source code?

-Claire


#5

Thanks for your answer Claire!

I’m currently experimenting with the range of the wixel, so I’ve used test_radio_signal_rx test_radio_signal_tx to test it. I want to be able to test the receiving end without being connect to a PC, but to a powerbank. When I used the original test_radio_signal_rx it didn’t work when connected to the powerbank. So, I thought, if I remove the USB sending stuff, it won’t freeze and it will indicate with the LEDs if it have received any packets. I didn’t think of the fact that it need some of that stuff to get into bootloader mode normally using USB. Well well, I thought, I’ll just reset it using the 3V3 and P2_2 as I’ve read many times. And now, it seems broken. If I connect it to my PC, the yellow LED is only glowing a tiny bit, the the application isn’t running, and it isn’t getting into bootloader mode. I don’t have the exact code, but I based it on the https://github.com/pololu/wixel-sdk/blob/master/apps/test_radio_signal_rx/test_radio_signal_rx.c

and if I recall correctly I removed the void reportResults() chunk, the usbComService() string and the reportResults(); string. I maybe also removed the usbInit(); string also, I’m not sure.

Images of the wixel:



#6

I do not think that loading that example with the USB interface stuff removed would damage your Wixel, so it seems like the issue is not code related. In your pictures it looks like there might be a little bit of globbed solder near the reset pin on the top of the board. Could you measure the voltage of the reset pin with just the USB connected like I mentioned in my last post?

-Claire


#7

Thank you Claire! I removed the solder residues, and the yellow LED didn’t glow anymore when I connected the wixel to my PC. I connected 3V3 and P2_2, and it worked! It got into bootloader mode and the wixel configuration utility recognizances the wixel!

A bit of topic, but how can I make the test_radio_signal_rx run on a powerbank? :slight_smile:


#8

I am glad removing that solder got the Wixel working for you. To get the test_radio_signal_rx.c program to use indicator LEDs instead of sending information to a computer, you should edit the reportResults function. You should remove the call to usbComTxAvailable and then replace the calls to usbComTxSend and the code that prepares the report strings with something that instead changes the state of the LEDs.

-Claire