Can't get Mini Maestro to move servos using Control Center


I’m a beginner with Pololu products and have fallen at the first hurdle: I have a 24-channel Mini Maestro connected to my laptop, and when I try to get a servo hooked up to it to rotate using the Control Center, nothing happens.

The laptop is a Windows 7 machine. The drivers appear to have installed correctly, and when I attach the board via USB the Control Center recognises it and doesn’t list any errors. I’ve set the serial mode to USB Dual Port, CRC is not enabled, device number is 1, Mini SSC Offset is 0, timeout is 0.00.

The board’s green LED is flickering constantly and the amber LED is flashing approximately once a second.

I have connected a 6v DC power supply to the terminal block, and have verified that 6v is available across the + and - pins of the output channels.

The servos I am testing with are these, apparently similar to the Hitec HS-55.

In the Control Center, channel mode is “Servo”, rate is 50Hz, min is 64, max is 2000, On Startup is “Off”, speed and acceleration are 0, 8-bit neutral is 1500 and 8-bit range is 476.25. When I enable the channel that the servo is connected to and move the position slider bar… nothing happens.

I’m pretty sure I’ve not put the servo in the wrong way round (from inside to out: white, red, black), and I’m definitely enabling the same channel that the servo is connected to.

I tried running the “simple servo sequence” script from the user manual - It executed without errors, but again, nothing happened to the servo.

One thing, though: The servos get pretty hot pretty fast when I switch on the DC power supply. I don’t spend enough time with servos to know if that’s to be expected.

If there’s anything really stupidly obvious I’ve missed please let me know! Failing that, any tips on how to go about troubleshooting would be gratefully received…



I am pretty sure the default device number should be 12. When making changes on the “serial settings” tab of the Maestro control center don’t forget to push the “apply settings” button on the extreme bottom right of that tab…it may even be off the bottom of the visible page on some screens. This caught me out for a while. Good luck.

Hi gordonsmith,

Thanks for the reply! I tried changing the default device no back to 12 (and remembered to hit "apply settings!). But sadly to no avail - I’m still not getting any movement…

Found the problem: I’m an idiot. I had my + and - back to front coming out of my servo power supply. Fixed the power supply and the board works fine (although I now have a couple of deep-fried servos that aren’t about to start spinning again any time soon…)