Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Can't get CP2104 to configure COM port in Windows 10


#1

I have been using the CP2104 adapters for years to connect my PC to various devices. All of a sudden today, I can’t get the com port to appear when I plug it in. Have plugged and unplugged multiple times. I’ve tried multiple different CP2104s and different cables and have re-installed the drivers, but no joy. When I look at Windows device manager, the PORTS option does not even appear in the device list. Help!!! Never had any issues with these devices before.


#2

Hello.

Have you tried using a different port on your computer or a different computer to see if that changes anything?

- Amanda


#3

Hi Amanda,

I tried two different USB ports, 2 different cables, and two different CP2104 modules. No luck with any of them. The system does not react in any way when I plug them in, but it works fine when I plug any other device into the same USB port. With the CP2104, it basically acts like I didn’t even plug it in.

I’m guessing its an issue with my computer (haven’t tried another one) but I reinstalled the drivers and that didn’t seem to help either.

Chuck


#4

Did anything change in your setup between when they were working and now (e.g. upgraded to Windows 10 or installed a Windows update)? Is the on-board green LED lit when connected to your computer? You mentioned re-installing the drivers for the USB-to-Serial adapter, did you use the latest drivers from Silicon Labs?

- Amanda


#5

Hi Amanda,

Yes, unfortunately I’m getting Windows 10 updates installed automatically all the time, which I hate - but there doesn’t seem to be any way to avoid it. The drivers I installed were the latest downloaded from the Silicon Labs site. No lights at all on the board when I plug it in - no sign of life at all - and nothing shows up in Windows Device Manager. I will try another computer later tonight and see if that works, but I really need to get it working on this computer, since it is where I do all my development.

Thanks,

Chuck


#6

OK, so I tried it on another computer and it didn’t work there either. Both these machines are running windows 10, one is a 32 bit OS running windows 10 pro. The other is a 64 bit running windows 10 home.

I downloaded the latest SI labs drivers on both machines… Most of my previous experience with these was on Windows 7 on a different machine, but that computer is broken so I can’t go back to it unless I get it repaired.

Are there known issues with Win 10 that I may be running up against?

Chuck


#7

Hi Amanda,

This morning I tried plugging the CP2104 into an older computer, running Windows 7 and here’s what happened: The computer immediately recognized that the device had been plugged in and attempted to configure it. But after a few seconds, it popped up a message that no drivers were installed, which may have been correct.

Then, I installed the latest drivers from the SI Labs site. After the installation completed, I again plugged in the CP2104 and guess what? Nothing happened - it didn’t even recognize that the device was plugged in. No beep, no message, no nothing. I’ve got to believe there is an issue with these drivers, but I have no clue what might be wrong. Any thoughts on where to go now would be appreciated!

Chuck


#8

We have not heard of others having trouble using the drivers for the Silicon Labs USB-to-UART adapters with Windows 10. I tested the latest drivers (v6.7.4) from Silicon Labs on a Windows 10 Pro 64-bit computer here and did not have any issues.

Can you provide the download link you got the drivers from? Can you open your Device Manager, select View > Devices by Connection, and try to find your USB host controllers and expand all their sub-entries, then post a screenshot of it so that I can see what USB devices your computer recognizes? They should be at a location like “ACPI x64-based PC -> Microsoft ACPI-Compliant System -> PCI Express Root Complex -> Intel® 8 Series/C220 Series USB EHCI (#1) -> USB Root Hub”.

Did you use the “Add Legacy Hardware” option to get both computers, running Windows 10, to recognize the CP2104 modules? If so, you should remove the entries created using that option, since it is only for older devices that do not support Plug and Play.

- Amanda


#9

Hi Amanda,

The driver version I downloaded was 6.7.4.261. I linked directly to it from the Pololu web site just to be sure I got the right one.

Attached is the list you asked for from the Device manager. This was done with the CP2104 plugged in. As you can see, the only device showing is my wireless mouse, which was plugged into another USB port.

I tried going the “Add Legacy Hardware” route at one point, but it didn’t work so I removed it. This computer is a USB 3.0 as you can see, but I believe the other two computers I tried were USB 2 machines.

I am using your USB to Serial Carrier (item 1308) because it is less expensive. Do you think your other USB-Serial carrier board would be any better?

I’m no Windows expert, but it seems like something is interfering with the “plug and play” operation.

BTW, I went into Windows System Setup under Apps and I found a reference to Silicon Labs (see enclosed screen shot), and I tried to uninstall it. When I did, I got an error (screen shot also enclosed). Not sure if this could be the cause of the issue or why it won’t uninstall. It says …slabvcp.inf not found. Don’t know if this is relevant or not.

Chuck

Chuck Davis


#10

Can you fully expand the “Mobile 5th Generation Intel® Core™ USB EHCI Controller” entry and post a screenshot of it here?

By the way, I removed the personal information you had in your post, since it did not seem intentional.

- Amanda


#11

No quite sure what you want here. If I double click on that entry, it gives me another dialog with 5 tabs, and each tab has some other sub-windows etc. How much of this do you need to see?


#12

I apologize; I should have made my question clearer. The screenshot in your previous post had a USB host controller entry, “Mobile 5th Generation Intel® Core™ USB EHCI Controller”, that was not expanded. Can you connect one of your CP2014 modules to your computer and post a screenshot of your Device Manager again showing that entry fully expanded? Please make sure to select View > Devices by Connection.

We are trying to find the entry that corresponds to your CP2104 in the Device Manager (if there is one) so that we can see what might be wrong with it and figure out why it is not creating a COM port.

- Amanda


#13

My turn to apologize. Out of desperation, I pulled another brand new cable out of the package and plugged it in, and it now works OK… Apparently the first two cables I tried were both defective - they are now in the trash. Not sure what there was about them that was different but they didn’t quite have the same “snap” when plugged in at the CP2104 end. They were probably 2 years old, so maybe they just wore out. I’m sorry for the wild goose chase, and I really appreciate the excellent support that you have provided. I’ve always had really good luck with Pololu products and services, so if you want a testimonial I’ll be happy to provide one!

Chuck


#14

That’s great Chuck! I’m glad the new USB cable resolved the issue; thanks for letting us know!

- Amanda