Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

Can't enter Zumo Pololu's bootloader mode


Hi, I recently bought a Zumo Pololu kit and I waited few weeks to receive my arduino Uno to make the zumo work.

I was excited to finally see my robot move, until … a problem.
I gathered all the required files ( Pololu A-star hardware files, Zumo32U4 library, … ) and I follow everything that is said here

And then occurs the “uploading” infinite loop, where my Arduino IDE tells me “uploading” for… well … the infinite.
I then searched a lot to find solutions to this problem and tried all those :

  • Change arduino card, I tried with my Mega2560 on it, and the robot made some moves, as I had old code on my mega.

  • Uploaded simply on the arduino’s some basic code ( by defining the card as the arduino, Uno / mega ) and this works, so the problem isn’t the arduino’s

  • Tried to go in bootloader mode while the arduino is connected on the zumo, as it seemed to work for everyone, and I just can’t get in that mode, my A-star board is just playing the “blink” code continuously and flashes the led 3 times when I hit reset, and does exactly the same when I try to hit reset VERY fastly just blinking the LED

I tried nearly everything I found on internet, but I am stuck with the bootloader mode, in which I can’t get.
As I understood, when I uploaded some code, maybe I plugged the usb cable too early, maybe it didn’t transfer well, and now, the A-star seems stuck in some code.

Hope you guys have some solutions, my school year depends majorly on that one robot…
Thanks a lot


As I read that for some, the COM4 port might work better than other ports, I gave it a try and uploaded the “MotorTest” example to my arduino Uno.

This is what I got.

        at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:141)
	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
	at processing.app.Sketch.upload(Sketch.java:1186)
	at processing.app.Sketch.exportApplet(Sketch.java:1160)
	at processing.app.Sketch.exportApplet(Sketch.java:1132)
	at processing.app.Editor$DefaultExportHandler.run(Editor.java:2381)
	at java.lang.Thread.run(Thread.java:745)
Caused by: processing.app.SerialException: Erreur de la commande « touch » sur le port série « COM4 ».
	at processing.app.Serial.touchForCDCReset(Serial.java:87)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:130)
	... 6 more
Caused by: jssc.SerialPortException: Port name - COM4; Method name - openPort(); Exception type - Port not found.
	at jssc.SerialPort.openPort(SerialPort.java:167)
	at processing.app.Serial.touchForCDCReset(Serial.java:81)
	... 7 more

Sorry for some parts that are in french.
I am trying all methods on my Mac and Windows at the same time, in case that could do something…


What I can do
I can put the blink example code on the arduino (defining the board as the Uno), then plug my arduino on the zumo, and the led on the A-star will begin to blink. BUT when i try to use code from the Zumo32U4 library, he doesn’t accept to upload that to the “uno” board, but only when I select the “Pololu A-star 32U4” board, it is THEN that the infinite uploading appears.

When I upload (for exemple MotorTest to the arduino while having selected the “pololu a-star 32u4” as board ), the led on the arduino blinks, like when I would transfer anything, it’s just that the uploading doesn’t end and doesn’t get replaced ( the blink stays after i upload something else )

(I try to add as much details as i can, sorry for “spamming”)



It sounds like you have a Zumo 32U4 Robot and want to communicate with it with a separate Arduino Uno. Is that correct?

Are you trying to load some example code from the Zumo32U4 library onto the Arduino Uno? If so, I do not expect the Zumo32U4 code to work on the Arduino Uno, which might be what is causing the issue.

Can you explain what it is you are trying to do? It is not clear to me why you are using an Arduino Uno with the Zumo 32U4.

- Amanda


No, what I am trying to do, is to make my zumo work.
Here is what I did :

  • I loaded the blink example code on the arduino Uno with as selected board on the IDE : Arduino Uno : Works.

  • Plugged my Uno with the blink code on it on the Zumo 32U4, makes the led on that robot blink too.

  • Plugged off the Uno of the Zumo 32U4 and changed the selected board on the IDE to : Pololu A-star 32U4

  • Tried to upload an exemple code from the Zumo 32U4 to the arduino, ends up in the infinite uploading

  • Tried to upload an exemple code from the Zumo 32U4 to the arduino WHILE it’s connected to the robot, ends up in the infinite uploading

  • Tried to upload the BareMinimum example to the Arduino, still as board : the Pololu A-star 32U4 and it ends up as the infinite loop

Conclusion : the uno works good, but I think the problem comes from the IDE with the board Zumo A-star 32U4. I tried to reinstall multiple times, changing machines, versions, but it doesn’t change anything.

My final purpose is to make my Zumo do examples from the library and that it works, for then, basing me onto those examples to code my own robot !

I am following this : https://www.pololu.com/docs/0J61/6.2
And as I understand this “tutorial” you are supposed to upload the robot sketch to the arduino, as specified board the Zumo 32U4, am I wrong here ?

Thanks again :slight_smile:


Ok I solved it by myself… You should upload from this library on the IDE with as selected board : the Uno or whatever board you want.

But still, I can NOT upload anything to the Zumo 32U4 board, and it is explicitly required to use this board when trying to upload any of the Zumo32u4 library kit from the arduino IDE. So this is still some secret for me …


It is still not clear which Zumo version you have, do you have the Zumo 32U4 Robot or the Zumo Robot for Arduino, v1.2? Can you post a picture of your Zumo without the Arduino Uno connected to it?

- Amanda


I have the Zumo robot for arduino, and that is what was not clear since the beginning, I since resolved all my problems, and have now a working robot, to which I am trying to make him use his reflectance array while being connected via telnet with an esp8266 module :wink: works great, thanks again !


I am glad you figured out the problem and are able to program your Zumo; thanks for letting us know.

- Amanda