Can't detect A-Star 32U4 Micro as USB device

I am using macOS, and my astar 32u4 micro is not detected as a USB device. Putting the controller into bootloader mode doesn’t help. I can see the LED pulsing, and it pulses a bit quicker when I short the RST and GND pin, so it seems like I am able to put it in bootloader mode. Nevertheless, I don’t see any devices in /dev/ttyusbmodem*. I have tried on linux and I don’t see any /dev/ttyACM0 device either.

Is it possible that astar I purchased doesn’t have the correct bootloader to be usb detectable?


We test all our boards before they ship, so it seems unlikely that your A-Star 32U4 Micro has the wrong bootloader.

Can you try using a different port and USB cable (one that you know is working)? Some USB cables (e.g. cell phone charging cables) are power-only cables and do not have the data lines. If changing the USB cable and using a different port does not help, can you run dmesg in a terminal immediately after plugging the A-Star 32U4 Micro board to your computer and post the output results here?

- Amanda

Thanks Amanda!

I tried your suggestion to use a new cable and it worked. I had used that cable in the past with no issue, but something must have happened to it since then.

Thanks again!