Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Can't control HD-1810MG servo with servo library on arduino

Hi, I’m kind of a rockie here, I have worked with servos before with the arduino servo library and it has always worked perfect, but it doesnt seem to work on my new Power HD Mini Digital Servo HD-1810MG I brought from this store, is there anything I’m missing? What should I do to control them.
(PD: I’m using an A-star LV board also brought from this store) Sorry for my english

Hello.

I am sorry you are having problems using your servo. Could you tell me more about your setup? How are you supplying power to the servo? Could you post your code and pictures of your setup?

- Jeremy

Sorry for abandonning this issue, if works of any help to anyone I solved the problem by modifying the code of the arduino Servo library. Turns out the library sets a frequency that works perfectly for analog servos (50Hz) in the initialization function, I solved the problem by just modifying that value for a valid one for digital servos (HD-1810MG is a digital servo) which is about 300 Hz, that value worked fine for me.