Can't connect to X2 for programming

Help please.
First time Pololu / AVR user.
I am unable to “connect” to the Orangutan X2 with USB/COM for device programming

USB Driver is installed, COM port is there, looks good.

In windows XP System Hardware, in device driver I have the following parameters showing:

Ports (COM & LPT)
Pololu Corporation
Pololu Orangutan X2 Serial Adapter

This device is working properly.

Drivers show Pololu Corporation
Date: 2/22/2007

I loaded a project using;
Atmel AVR IDE Version 4.17 build 666

ATmega 168 is in programming mode (green and yellow LEDs)

From the IDE I use:
Tools – Program AVR

Or other serial ISP devices
Also tried default baud of 115K (normally 9.6K)
Also changed to COM2 that is not used.
The Problem, the IDE always returns
“Connect failed - Select AVR Programmer”

Seems that I am missing something basic here,
Any suggestions?


I don’t see anything wrong with what you’re doing. Do you have WinAVR installed? Have you ever been able to program your X2? One thought is that maybe the USB cable you have is faulty. Do you have any other A-to-mini-B cables around you could try?

- Ben

Thank you Ben,

I had a chance to look at ‘connect’ problem some more now:
I loaded WINAVR as well and tried the dude but couldn’t open the port there either.
I then found this neat Realterm serial COM program. It is not relevant to the project but it allows me to experiment with the COM ports. Also uninstalled and reinstalled the Pololu USB/COM drivers. All works as expected the COM is visible in the device manager. When realterm scans for ports on startup it does log a COM4, the Pololu serial COM driver, and list it in the available COMs. However if I try to open it I get “The parameter is incorrect”. And the port can not be opened for the Pololu port. If I choose another COM like COM3, the built in MODEM, it opens properly and everything works for that port. If I power down the X2, of course COM4 is not there and Realterm does not have it in the list of available ports. Does this give you any hint as for the failure to connect with the 2102? Realterm seem to be able to ‘see’ COM4 and list it but not to open it.
I assume that the open port would occur at the 2102 level regardless of the 168
Meanwhile I am using AVR Studio 4 I have built and simulated a project and I like the software very much. Realterm also seem wonderful utility to me. The X2 with its preloaded test program is very nice, pot/motors/readings all good. If I could only ISP it already. X2 also resets fine into the programming mode. I might have to try and load the software on another computer. I can’t see why it wouldn’t connect.

I think it would be worth trying it on another computer. It would also be worth trying it on a different USB port and with a different USB cable (if you have one).

- Ben

This might be useful info, really unexpected result.
I tried different cables all USB ports etc. no change.
Tried loading same software packages and drivers on a second computer. Everything was the same, same messages, same plug ins reporting same drivers behavior. Then when selecting connect, connect is successful first try. Even without a project loaded or device selected or using a different ISP type I was able to connect one way or another. Does not seem like a hardware issue with the first computer yet it would not connect on computer #1. I then uninstalled all related software and drivers from #1 and even manually erased any residual files. I Then reloaded all software and drivers and ran the same project files and definitions off a USB stick, same for both computers (both XP etc). Computer #2 connects fine ! Computer #1 does not. No hint or any error message to suggest a difference between the computers. The only difference is the “Connect faild - select AVR programmer” in computer #1. I guess given it is the first time I use any of this Atmel hardware and AVR software I was unlucky not starting with computer #2 first…
I am still curious about this.

Well, since it works normally on your second computer, I think it is very unlikely that there is a problem with the Orangutan X2. Rather, I think it’s likely that there’s an issue with the CP2102 drivers conflicting with something about your first system. Perhaps something you have previously installed or some device you have connected to your first computer is interfering with operation? Can you try reassigning the programmer to a different COM port on your first computer? Do you any other serial devices connected to your computer that you can try disconnecting?

- Ben

I agree with you, I never had a concern about the Orangutan X2 hardware. It has been consistent.
As for the COM port, I have tried assigning other COM numbers on #1 with no different results. i.e the port is visible, listed, detected by terminal program but not by AVRISP connect. I have also experimented with a different emulated RS232C COM port via USB adapter cable that is similar case to this and has its own USB driver. That one works fine and ‘opens’ another COM port just fine in computer #1. What I did next is trying the ISP on a third computer. Everything worked fine right away. Based on this I have capped my curiosity about computer #1. I will keep you posted if I find anything new about this one.
Thanks for the help.