Can't communicate between PC & 3pi with AVR Programmer

I’m not a computer person and don’t totally understand - but have followed instructions & have AtmelStudio 6 up and running & have followed getting the 3pi_app2 build solution without errors (F7) . But when try F5 to load program onto 3pi I keep getting following: [ERROR] Could not establish communication with the tool., ModuleName: TCF (TCF command: Tool: connect failed.)

I’m on Windows 7.

I have a green led on programmer - solid green - and an amber blinking led. 3pi is on & I have run the demo program and everything works great.

I just don’t know if it’s a COM port problem or what. I don’t understand even how I would change that if it were a problem. Sorry. I tried to follow trouble shooting, etc. but get lost and don’t know where to go from here.

Any help would be greatly appreciated, as this is all new to me. I’m not a computer expert by any means!

Thanks so much!


Hello, Chuck.

I am sorry you are having trouble. Could you please post a screenshot of your Device Manager with the Ports (COM & LPT) section expanded? This will let us see what COM port the programmer is assigned to. You can use the “Upload Attachment” tab, which is visible below the “Submit” button when you are writing your reply to attach the screenshot.

Are you sure that was the entire error message? Are there any relevant lines of text before or after the line you posted?


Thanks David - I really appreciate your help with this.

It looks like its COM4 - and I’m not sure, but I think AtmelStudio 6 is defaulting to COM3 - but not sure.

Here’s the screen shot - I think this is what you asked for, but not sure.

Yes, I’m pretty sure the error message is the only message - it appears at bottom of AtmelStudio page each time I try to load program onto the 3pi - but that’s all I think. Sorry for the trouble.

That was a screenshot from the “Devices and Printers” window. You should also check in your “Device Manager”, and make sure it looks something like this:

It looks like your programmer is on COM4. Now let’s check your Atmel Studio configuration. Could you click “View” → “Available Atmel Tools” and then take a screenshot of the dialog box that pops up?


Thanks David. I appreciate your help.

Here’s the screen shot you asked for of Device Manager, and also of the box that pops up from Atmel. It does look like the ports are different - but I can’t figure out how to make them the same… Sorry.

Thanks again,


Ah, there’s the problem. When you added the STK500 to Atmel Studio, you should have chosen COM4 because that is the Programming Port. Please right-click on the entry for “STK500 (COM3) Program only” inside Atmel Studio and remove it. Then do the “Tools > Add STK500…” step again, this time choosing COM4. After that, F5 should work for programming.


Thanks so much, David! It worked! I so appreciate your help, and sorry to bother you!

All the best,


I’m so sorry for more questions, but I have spent the last week trying to find and load the line follower program for the 3pi from the Library - but can’t find it on my computer. I wish I knew more about computers, etc. - but I thought the entire library was downloaded when I was doing the set-up, but when I search on my computer for a file starting with the word “example” nothing comes up that has anything to do with the Pololu or the Atmel program, etc. so that must mean that the Library was never fully downloaded…? Do I go back and repeat the set-up process?

Thanks so much for helping and guiding me!


Hopefully you installed the library in the default location, which is C:\libpololu-avr. Do you know how to navigate to that location and look at the files there?


Thanks David! That’s what I missed - the main folder name. I was able to find that folder, and I double clicked on the linefollower-pid and it opened in Atmel Studio 6 - then I was able to get it to download to the 3pi!

And it worked! So I’m getting there! Now I’m trying to figure out how to increase the speed of the 3pi as it follows the line. Is there some easy way to do that, or do I need to get into the code and do it there and then re-compile and redownload? I can’t seem to figure out how to SEE the code in Atmel Studio 6. There’s just a dark blue screen on most of the page, with the “Solution Explorer” on the far right. But I don’t see any code to change the speed of the 3pi as it travels along the line.

Thanks again for your help - I REALLY appreciate it!

All the best,


Try double-clicking on some files in the solution explorer.

Yes, you will need to recompile the code to change the speed.


Thank you, David for your help again. That did it!


Hi, I am new to this forum. I have 3pi that I have been trying to get up and running. I read this post as my errors seem to be the same. The port I am using is COM7 (Pololu USB AVR Programmer TTL Serial Port (COM7). Everything appears to be working fine but I when I click F5 or Continue I receive the error “Unable to start debug session Atmel Studio was unable to start your debug session. Please verify device selection, interface settings, target power and connection to the target device.” The Details indicate ComponentID=20100 | StatusCode = 1 | ModuleName=TCF (TCF command: Tool Connect failed.) The signature of the attached tool is AVRISP_2, which is unexpected.

Another note: I originally tried COM6 Pololu USB AVR Programmer Programming Port (COM6), but after reading this post I decided I should use COM7.

Thank you in advance for any help.

Hello, Bonnie.

Chuck’s problem was that he was trying to use the TTL Serial Port to program, but you need to use the Programming Port. Please try using COM6 and let me know what error message you get in that case.

The error message you reported (“The signature of the attached tool is AVRISP_2, which is unexpected.”) makes it sound like you were actually using the correct COM port, but your programmer has an old version of the firmware. Where and when did you get that programmer? Please see the information I have written about that error message in the “Troubleshooting” section of the Pololu USB AVR Programmer User’s Guide.


Hello David, Thank you so much for helping. My firmware version 1.01. This is actually what we came up with when troubleshooting as well, we believe that it needs to be 1.03. I get the same messaage when using COM6 as well. Updating the firmware seems to be a challenge. If I bought a new connector do you thinbk it wouyld have the correct firmware version? Thank you, Bonnie

You should use the latest firmware version, which is 1.07. If you buy a new programmer from us, it would have version 1.07. However, you should be able to just update the firmware on your existing programmer yourself over USB without any additional purchases; that’s the value of having a bootloader. If you try the firmware update procedure, let us know if you run into any trouble or if the instructions are unclear.


Hi David, Thank you again for your assistance. We decided to order a new Pololu USB AVR Programmer - Salesorder 1J105842. I really want to have this working this coming weekend. So, per your post, I am assuming that this one will have the correct firmware rev. Sincerely, Bonnie

In the meantime before your new programmer arrives, you could use AVRDUDE instead of Atmel Studio to transfer the HEX file to the 3pi. There is a section about using AVRDUDE in the Pololu AVR Programming Quick Start Guide: