Cannot run test-simple SVP linux

I recently received an orangutan svp 1284 and have read the documentation to make sure I didn’t miss something obvious, because this feels like a question with a very simple answer.

The default program worked out of the box (and I do have version 1.03), but I haven’t been able to load any firmware to it. I am using examples from the libpololu-avr library, libpololu-avr/examples/atmega1284p/simple-test, in Linux.

As described in the documentation, I made the hex files and tried to run make program to upload the new program, but the outputs I am getting from avrdude are :

       avrdude: Device signature = 0x1e9705
       avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed
                To disable this feature, specify the -D option.
       avrdude: erasing chip
       avrdude: stk500v2_command(): warning: Command timed out
       avrdude: stk500v2_command(): command failed

One time, randomly, it looked like it was working, but ended up just wiping the default program instead, now i get a blank lcd and still cannot upload the new program. Is there something obvious I am missing like a jumper position or a programming mode setting? Thanks

Thanks to David Grayson for pointing me to the guide that I had already read a few times, but obviously skipped this part each time (I skipped over the entire windows explanation section and jumped right to the linux part!).

So, the resolution is explained perfectly at the very end of the Windows section.

I am glad you were able to solve your problem. Actually, I should have pointed you to the “Compiling an Example Program in Linux” section because it has the same note about how you need to change avrdude.conf.