Cannot operate servos: Mac OS X host with VirtualBox Windows10 or Ubuntu guests

I am using a Micro Maestro 6 Servo USB Controller.
My goal is to operate this controller using a Raspberry Pi 3, but before I do that, I need to verify the connection. My operating system is a Macbook Pro running OS X 10.14.6 (Mojave). Since this OS is not supported, I am trying to run the Maestro Servo Control software on a VirtualBox.

I have now tried this with both Win10 and Ubuntu 18 virtualbox setups, following all of the install instructions.

In both cases, I am able to get the Servo control software to open and to connect successfully, but the servos simply do not move when I click their checkbox and move the slider.

I have verified the following:

  1. servos are connected correctly to gnd, pwr, sig pins
  2. servo controller board has servo power from a 5V input
  3. servo controller board is connected to computer with USB
  4. servo controller board was successfully updated with 1.04 firmware upgrade which addresses modern Mac usb/com issues

I have read in other forum posts that there is some issue with virtual com ports and possibly usb connections when using Mac OS. I have also read that there is some known issue with Mac and VirtualBox where the connection only works the first time.

I am just trying to get a basic “Hello World” example, to see that the servos move when I move the sliders on the screen. Does anybody have a successful experience running the Maestro control software on a Mac OS host with either a Windows or Ubuntu guest using VirtualBox?

Thank you.

Ok! I have quickly solved my own issue. I’m leaving this topic up for the benefit of anyone else who might have the same problem.

The problem was that I had external power connected to the VIN & GND pins on the 5-pin strip used for communications/logic.

Instead, the power supply had to be connected to the +/- pins at the top oft he servo rails.

Once I did this, the servos worked just fine. :slight_smile: