Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Cannot continuously upload programs to devices

Hi I have a Pololu v2.1 firware 1.0.2

And I can burn bootloader just fine, after burning bootloader I can upload program just fine.
So what is the problem?
Well, after doing the above with success, I want to upload a program again, so I press upload in Arduino IDE and it starts uploading, but fails with:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

I tried disconnecting the programmer and connecting it again. I tried resetting the target. I tried a LOT. Nothing helps.

The only way to program it again is by uploading a new bootloader. And then upload new software. But that is waay to inconvenient.
Any ideas?

Thanks in advance.

BTW, yes. Connections has been checked. I have checked that I select the right ports. Actually I can press upload (with success) then press upload again and it fails.

Hello.

I am sorry you are having trouble with the Pololu USB AVR Programmer v2.1.

When you try to upload to your board using its bootloader and get a “programmer is not responding” error, I suspect that means the board is not actually in bootloader mode, so the board doesn’t respond when AVRDUDE tries to talk to it.

  1. What specific board are you using?
  2. What bootloader are you loading onto it?
  3. What mechanism are you trying to use to get the board into bootloader mode when you click the upload button?
  4. Does the bootloader blink an LED or something like that so you can tell when it is running?
  5. How is everything powered and connected?
  6. Can you post some pictures of your system so we can check the connections?
  7. Can you post a screenshot of the Pololu USB AVR Programmer v2 Configuration utility so I can see what settings you are using?

–David Grayson

No no.
Process is.

I upload bootloader. Works fine.
I switch com port and upload program. Works fine.

I then make modification to program and try to upload. But now it fails.

So I have to switch back to previous port, upload bootloader.
Switch port and upload program

I would have liked it to be as when I use Arduino as iso. Because that works.
The step there is.

Upload bootloader. (Using Arduino)
Upload program. (Using chip less Arduino)
And now I can repeatedly upload program without having to upload bootloader first.

Policy forces me to upload bootloader before i upload program every time.

In addition. I can program fine. My devices work fine. I’m just annoyed that I have to upload bootloader first Everytime on the same chip.

So programmer and my device work fine. Just the annoyance of having to upload bootloader before uploading program.

I know that i need to upload a bootloader. But I should only need to do that once.

I understand that the bootloader works once for you, right after you program it. You did not say what specific board or bootloader you are using, but perhaps the first upload works because there is no sketch loaded on the board, so instead of running the sketch, the bootloader just stays in bootloader mode and it is ready to receive commands. When you press the upload button to perform the second upload, you need some mechanism to get the board back into bootloader mode. The standard way is to use the programmer’s “B” pin (which is configured to output the “DTR” signal by default) to trigger a pulse on your Arduino’s reset line. If you can answer all of the questions from my first post, then I can help you make sure that you have set that up correctly.

–David