Can anyone confirm serial_set_baud_rate behavior?

Hello -

For some reason I can’t seem to get the 3pi serial_set_baud_rate to work at 9600?

Here’s what I noticed:
I’m setting up my 3pi to be a wireless slave with a BlueSmirf BT card. The natural default baud for the unit is 9600, so the plan was to send the necessary commands at 9600, to set the BlueSmirf baud to 115200 to be compatible with the pololu slave code. No such luck.

Now, I had read a number of posts on different forums about the woes of BT connections. So I started out by working though the commands and sequence of commands using my laptop and Desktop computer. Next came issuing the same commands from the 3pi. For that effort, I had the 3pi connected directly to the desktop with a TLL level converter.

I started using the default 115200 baud from the Slave code. Worked like a champ. Changed to 9600. No luck. Trying different Bauds, serial out from the 3pi worked fine down to 38400 - lower than that was garbled. (yes the 3 pi was fully charged).

I have since managed to set and flash the BlueSmirf configuration settings to a default baud of 115200, and am successfully communicating with the 3pi - But it just seems odd that the 3pi would not output at 9600? I would have expected to see problems at the higher speeds, not the lower.

Has anyone else seen this behavior?

Paul G.

Hmm. I think that code should work at 9600. Are you sure that your device was really transmitting at 9600 baud? Is it possible that you or your OS were setting the baud rate on the COM port to something other than the “default”?


Paul -
As with my slave code issue, my version of WinAVR, was 20090313. Installing the latest version 20100110, and the latest Pololu Library seems to solve the problem as 9600 baud now works just fine.

Thanks for the help.

Paul G.