Baby-O Unable to Connect

I have been using a baby Orangutan for a few months in a design project using AVRStudio 4 and Windows XP. Until yesterday, everything was working flawlessly. Then, suddenly, the AVRISP programmer was unable to connect to the board. The red LED that had been lit by the most recent program flash is no longer lit, although the green power LED is.

We have done as much testing as we can on the board and found all the peripherals to be working: the resonator, the voltage regulator, continuity to the ISP header pins. I have even tried using a Windows 7 system and two other programmers with the same result. Can I tell for sure if the MCU is busted?

  • Thank you


Can you describe exactly what happened between when you last successfully programmed the board/saw it working as expected and the first time you noticed a problem? Do you remember anything strange? Did you change any of your connections?

- Ben

I programmed the latest build and then ran the program a few times to see how the program altered DC motor states based on sensor data. Power to the entire system was cut, I made a few changes to software and compiled, plugged in the ISP cable, and turned on the robot.

I occasionally get errors with the XP drivers saying something along the lines of “Please upgrade before reconnecting,” upon which I just unplug and replug the USB cable. So, I did. Then, having re-established communication with the programmer, I attempted to program again. This time, I got a message about checking if the ISP connector was in backwards, which it was not. The red LED was on, indicating that my old program’s initialization routine had been completed. So I decided to try to erase it, which shut off the LED but also indicated that erasing “FAILED!”

And that’s about it. I haven’t done anything majorly wrong with power connections or knowingly changed any fuses.

What programmer were you using when this happened, and what other programmers have you tried?

- Ben

I have been using the AVRISP programmer that comes with the combo deal. I have also tried other AVRISP and an AVRISP mk II.

Unfortunately, I don’t really have any further troubleshooting suggestions for you; it sounds like the MCU has been damaged or corrupted somehow. The programmer errors you mentioned are a little concerning, though, as it makes it sound like the programmer might not be functioning properly, and problems during programming can disable an AVR. I think you probably need to replace the Baby Orangutan. If you email us, we might be able to get you a discount on a new one.

- Ben