Baby-O Program Issue

I looked through some of the threads, but didn’t really find the answer. I’ve been programming the Baby-O without issue for awhile, but now I suddenly can’t download. Here’s the error:

Erasing device… OK!
Programming FLASH … OK!
Reading FLASH … OK!
WARNING: FLASH byte address 0x0006 is 0x51 (should be 0x3E)… FAILED!
Leaving programming mode… OK!

I can upload the current Baby-O flash from the controller to a file and can also read the signature. I went back and tried to load the LED sample program again, but receive the same type addressing error (different address though), so it doesn’t seem to be the program itself. Nothing has changed in the programmer that I am aware of. The fuses are 0xFC, 0xD9, 0xF6 for ext, hi, and lo.

Help, I’ve run out of ideas…


How are you powering your Baby Orangutan and what are you using for your programmer? What error do you get when you try to read the device signature? Have you tried cycling power on your programmer and restarting your computer?

- Ben

Hi Ben,

Power is from a 12.5V source. I’m using the Pololu USB AVR programmer.

I can read the signature OK. The only error I get is when I try to download the flash.

I have rebooted & cycled programmer power.


Your fuse bytes are correct. What is your 12.5 V power source? How repeatable is the error? If you try programming the same hex file multiple times, does it always report the same wrong value at the same flash address?

Can you run the programmer’s configuration utility and tell me what ISP frequency you are using? If you haven’t already, can you tell me what happens if you change the ISP frequency to 200 kHz and try programming again?

- Ben


I’m using a 12V gel cell with a 6V regulator.

I installed a new Baby-O, and it is working correctly using the same programmer. I assume that the problem is with the original Baby-O since I was unable to download any new code to it while the new one is working correctly.


Hmm, it sounds like the microcontroller might have been damaged, in which case, unfortunately, there isn’t really anything that can be done to salvage the Baby Orangutan short of replacing the MCU. Is there any chance you accidentally exposed the MCU pins to out-of-spec voltages or static-zapped the board?

- Ben