AVR USB Programmer

Since I’ve upgraded to Windows 10, I seem to have trouble accessing the serial ports on the programmer. Sometimes it works, mostly it doesn’t. Anyone else seen this or is it just me?

Hello, Martin.

I am sorry you are having trouble using your AVR programmer on Windows 10. We tested the programmer on Windows 10, but we do not use Windows 10 regularly so it is possible there are some problems we have not caught. For Windows 10, Microsoft rewrote the driver used by the programmer’s serial ports (usbser.sys), so it would not be surprising if its behavior has changed in some way. Can you post a screenshot of the error or error message you are seeing (if any) as well as a screenshot of your Device Manager when your AVR programmer is plugged into your computer?

- Amanda

Sure, I will try to get a screen shot up this evening.

Basically, it just says in a small pop-up window ‘can’t configure com9’. If I look in device manager, it verifies that both the programmer port and serial port are there on com8 and com9. I have two programmers, the other one is com6 and com7 which I also see if I plug it in.

I have found that if I just keep trying, sooner or later it will work. Sometimes it takes many tries, (like 10) but eventually comes up.

I use putty to connect to it. I have tried other serial term packages and they do the same. I do recall reading about MS re-write of this for Win 10. Figures they would break something :slight_smile:

But as long as I can just keep trying and it eventually comes up, that is at least a work-around.


I tried to reproduce the issue here using our Windows 10 development machine, but I was unable to. What version of usbser.sys is currently running on your computer? (You can check what version of usbser.sys driver you have by looking in the “Details” tab of the “Properties” window for C:\Windows\System32\drivers\usbser.sys.)

If you have not already done so, you might consider trying a different port, a different USB cable, or a different Windows 10 computer to see if that changes anything.

- Amanda


As promised, a screen shot. I should mention my Win10 is from an upgrade of Win 7 so who knows what went into that.

If I just keep trying, eventually it will work.

I verified that your usbser.sys file version matches with the file version on our Windows 10 development machine. Unfortunately, I was unsuccessful in replicating your issue. Have you tried any of the suggestions in my last post about connecting your programmer to a different Windows 10 computer or using a different cable or port? It could help determine if the issue is due to Windows 10 or just your system in particular (like if something weird happened during the upgrade from Windows 7 to Windows 10).

- Amanda

It’s looking like it’s just a weirdness with my Win10 upgrade. It’s pretty repeatable for me. I try four or five times, then it starts. I’ve tried different ports and I even have two programmers, same thing on both. As long as it eventually starts it’s fine. I leave it up for my entire coding/debug session so once it’s up, I’m good. Thanks for looking into it.