AVR USB Programmer: Reinstallation fails


I have problems with the USB driver of the programmer working with Windows 7 64bit

I bought it a few days ago and was able to install the USB driver (I used the driver package only from here:
pololu.com/file/0J486/pololu … 110524.exe, not the complete installation bundle, and installed WinAVR separately)

The driver showed up in the device manager, and programming to the chip (ATMega1284P-PU) worked fine.

Now a few days later, the USB package does not work any longer, I get a unknown device message when I connect it to the PC. I tried to deinstall (via Software / deinstall) and reinstall it, but probably deinstallation does not work properly, because with my next installation, the installation windows do not show up the same way as the first time.

When I plug in the USB device, I always get to blinks at the green LED of the device, and then nothing.

Answers which might help:
1.) How do I completely remove the USB driver from my system for proper reinstallation?
2.) Might it help to reflash the device (I have another programmer of another type here), does that work?

Any input appreciated,



Some more insights:

It seems that the USB driver works with actual Win 7 64 only as long as you have NOT booted the system. I just tried it with another computer, driver worked fine, I could connect the plug and saw the COM ports in the device manager. The green LED was permanently on, and the red flashing (there is no board connected at the moment). I could also connect with your configuration tool.

When I reboot the computer, everything is lost, as soon as I plug in the USB device, windows again tries to install a driver, but not the correct one.

The screenshot of that new driver is attached, maybe windows is automatically replacing something?

One other thought/remark: I am working with a restricted account, so I have to input an admin password each time I install. Have tried installation under admin, but does not change anything.

It would help to get again at least to the stage where I can freshly install the driver, I would accept to have to install that driver each time after reboot (you see that I am not greedy :wink: )

Hello, Thomas.

Your Windows thinks that the USB AVR Programmer is an “Unknown Device” which makes me think that something is going wrong at a very low level. Even if the programmer’s drivers are totally missing from your system, Windows should be able to identify the programmer as a USB composite device, create a device entry named “USB Composite Device” (with hardware id “USB\VID_1FFB&PID_0081&REV_0105”), and create three child devices:

  1. Pololu USB AVR Programmer (with hardware id “USB\VID_1FFB&PID_0081&REV_0105&MI_04”)
  2. Pololu USB AVR Programmer Programming Port (with hardware id “USB\VID_1FFB&PID_0081&REV_0105&MI_00”)
  3. Pololu USB AVR Programmer TTL Serial Port (with hardware id “USB\VID_1FFB&PID_0081&REV_0105&MI_02”)

Please go to your Device Manager, in the View menu select “Devices by Connection”, then find the Unknown Device that corresponds to the programmer. Please post a screenshot here so I can see where it is in the tree of devices on your system. Also, please double click on it, go to the Details tab, and tell us what its Hardware Ids are.

On my Windows 7 64bit machine, with the drivers properly installed, the Device Manager looks like this:



thanks for your prompt feedback. Have attached the requested screenshots.

Best regards,



I think that I have solved the problem by chance, you were right with your assumtion “very low level”. When I did the screenshots, it suddenly worked once when I touched the usb plug at the board. I unplugged and replugged this USB Plug, and now it seems to work. Either a bad connection or something in the soldering.

Thanks for your help.