AVR usb programmer problems

I recently acquired an Pololu USB AVR Programmer. I have been trying to make it work without successes.
It doesn’t work in AS 6.o or with avrdude.
I check the firmware: it is 101 So i wanted to upgrade it but the pololu utility does not connect to the programmer : error code 0x514
I have windows XP service pack 3.
Pleas help.

I have recently aquired an Pololu USB AVR Programmer but it does’t work.
I installed all the drivers, I have Windows Xp with service pack 3. I followed the instructions to program with atmel studio and with avrdude but non was successful.
I want to upgrade the firmware ( my is 0101) but the utility cannot connect to the programmer. It gives me error code 0x514.
The green led is solid an the red is flashing.
Pleas help.


If the firmware version of your AVR programmer is 1.01, it will not work with Atmel Studio 6. You will need to upgrade the firmware to use it.

It sounds like you were following the instructions found in “Upgrading Firmware” section of the Pololu USB AVR Programmer user’s guide. At which step do you get the error? As noted in the instructions, if the firmware is corrupted, you will not be able to use the “Start Bootloader” feature of the utility and you will have to use the programmer’s bootloader pads to get the programmer into bootloader mode.

- Jeremy

I can not even connect my programmer to the utility. As soon as I open the utility the error pops out.

If you cannot connect the programmer to the utility, it sounds like the firmware on the programmer might be corrupted. You should try getting the programmer into bootloader mode using the method described in the guide that uses the programmer’s bootloader pads and follow the rest of the instructions for upgrading the firmware. You will not have to connect to the utility if you use the bootloader pads to enter bootloader mode.

If you continue to have problems, could you post a screenshot of the error that pops up and a screenshot of your Device Manager?

- Jeremy

Thank you. Now it works.I am able to program the AVR. But I am still unable to connect to the utility : error code 0x514.
Does this type of error happen frequently?

We have not heard of this issue before. Did you download the software directly from our website? If not, could you try downloading and reinstalling the AVR Development Bundle found here and see if that fixes the issue? If that does not work, could you post a screenshot of the error that pops up?

- Jeremy

Yes I have downloaded the software directly from your officialpage.
The screenshot is in my attacments

I am going on a short vacation so my response may not be immediate

Error code 0x514 is a Microsoft error code related to privileges. Could you try running the utility as an administrator and see if that changes anything?

- Jeremy

I am back from my vacation.
Yes it was just an Microsoft privilege problem.

Thank you for your help.


I have a new problem:

I know I have seen some tips for this error but I can’t finde it again.

Help :blush:


The signature is the ID specific to the AVR. It looks like you have ATmega88P selected as the device, but you are trying to program an ATmega88. You should select the correct IC in Atmel Studio and see if the error goes away.

- Jeremy

It worked.
You must be a genius.