AVR USB Programmer Drivers will not Install

Hello Friends,

Just recently bought the AVR USB Programmer and unfortunately the drivers will not install. Windows can’t match the hardware with the latest drivers ‘pgm03a_windows_090624’. Has there been a firmware update and the online drivers are running a bit behind?

Side notes:

  • Control panel tells me the hardware Rev is 0101, but the software drivers are 0001.
  • My system is Windows XP SP3 and my usbser.sys is the correct version.

Happy Holidays!

Hello, Jason.

Thank you for determining the exact cause of the problem!

I just fixed this problem and made a new release of the drivers for the programmer, available in the programmer’s resources tab and in the User’s Guide. You can install the new drivers without worrying about uninstalling the old ones.

The new drivers do not refer to the firmware version number, so they should work for all past and future firmware versions.


Thanks David!

Works like a charm.


Can’t get driver working in Windows 7. Installed according to directions. Windows came up twice and asked me if I wanted to install driver, clicked install anyway. When I plug programmer, Windows canot find a driver for it.


What version of the drivers do you have? You should have the latest release, pgm03a_windows_091222.zip.


Yes that is the version I downloaded. The a previous worked for me, but could not get this one to. Is there an archive of old versions?

I am experiencing a similar problem. I am using windows 7 64bit.

I tried to install release pgm03a_windows_091222.zip

when I right clicked on pgm03a.inf and selected “install”, nothing happened; I was not even given a prompt asking me if I would like to “install anyway”

I tried to install version pgm03a_windows_090624.zip but ended up with the same result.

KaiZ, when you plug a programmer in to your computer, what messages do you see? Does the programmer show up in your device manager correctly?

The selecting “Install” on pgm03a.inf should work eventually (it might a minute or two). But if it doesn’t work, there’s a way to tell windows to explicitly use the .inf files. To do this, plug the programmer in, go to the Device Manager, right click on an improperly installed entry relating to the programmer (any entry in the “Other Devices” category is improperly installed), select “Update Driver Software…” and then select the folder that contains the .inf files you downloaded. If that doesn’t work for you, let me know exactly what error message you got at that point.


David, your advice worked, thank you for the quick answer!

I too seem to have this problem. I use D: drive for windows XP, Home edition SP3, and installed the drivers from the win_cp2102_drivers file to D:\Program Files\Pololu\usb01a. That went ok, but then when I plug in the programmer, and go through the Found New Hardware wizard, and point to the location for the drivers, I get a message that the drivers could not be found, and the installation fails. Looking in Device manager shows the expected "Other Devices " list of Pololu USB AVR Programmer, Programming port, and TTL serial port, but attempting to reinstall the drivers there still returns the message “The hardware was not installed because the wizard cannot find the necessary software”. I also tried removing the drivers, and re-installed to C:\Program files\Pololu\usb01a, but that did not work either. I do not find anywhere on my system the file usbser.sys Is this only part of XP Professional ? Please advise.


It sounds like you’re mixing up different programmers and drivers. You should pay close attention to what unit you have and follow instructions and install drivers appropriate for your programmer. If you continue to have problems, make sure to be clear about which product you’re talking about.

- Jan

I just recently bought the Pololu AVR programmer, your item number 1300, and your site shows the pgm03a_windows_091222.zip file as the source for the drivers. That file contains PololuUSBInstaller.exe, which then contains and installs the drivers pushbus.inf and so on. Is that correct ?

Red Face ! I unzipped the wrong file. When I got the correct file and unzipped that, the installation worked properly :slight_smile:

Great! Thanks for letting us know things are working.

- Jan

Maybe this will help someone : i have a Vista install which has had trouble with driver installations for a while, so i’ve reset my driver cache.

I could install “Pololu USB AVR Programmer” fine, but the serial port driver install always failed with “could not find the file” message. After digging around in setup api logs, i found out that it was looking for usbser.sys under %windir%\inf and failed there.

So manually copying usbser.sys from %windir%\system32\drivers\ to %windir%\inf ( go figure ) solved my problem.