AVR Studio 4.13 Released (sort of)

Atmel Norway put out a release version of AVR Studio 4.13 this morning, but it isn’t available on the normal Atmel website yet:


I’ve been using a previous release candidate for a little over a week now, and it is very nice. The main advantages over Studio 4.12 are:

  1. File Tree and IO windows are separate and displayed simultaneously by default. You can probably do this in 4.12, but I didn’t think to try until I saw it and thought “Now that’s better!”.

  2. A few bugs fixed, including one that made Studio crash on my home computer (and a friend’s computer, but not my work computer, weird!) whenever I tried to run a simulation.

Only problem I’ve had with 4.13 so far is it got confused once when I created a new project after having an old one open. When I tried to build, it tried to build both projects, got confused, and threw some equally confusing warnings:

-Build succeded, 0 errors, 0 warnings
-Build failed

I closed Studio, reopened the new project, and it worked fine. Maybe they fixed that too in the actual release version; I’m downloading it now!


Unplug your AVRISP mkII (if you have one) so the installer can update its driver. Took me a few minutes to figure out what it was complaining about.