AVR Programmer

Running Windows 7/x64. Using the AVR/USB progammer with an ATTiny861. All was working fine, until recently. Now, with AVR Studio, I can’t connect to the MCU. Status leds on the progammer are solid green, and blinking yellow. I know the processor is running, because I have a test program on it, and an LED is displaying as expected. No error from AVR Studio. The connection dialog just keeps coming up with no success. I looked in the Windows 7 device manager, and the virtual COM port is there (but with a warning icon). Any clues on how to figure out why connection is failing?

FYI, I also tried several different MCU chips, and all exhibit the same problem. So, I am assuming it is not the MCU itself. Any suggestions?

The “USB AVR Programmer” installed, but the "USB AVR Programmer Programming Port (COM3)"
and “TTL Serial Port (COM4)” Failed to install.

Another update. I had installed some Windows 7 “updates” that then failed. I restored to a prior restore point, but wonder if usbser.sys hs changed? How to figure this out?

FIXED THE PROBLEM! Beware Windows 7 users. One of the Windows updates I installed has a newer version of usbser.sys, dated 11/20/2010.
This version of the driver seems to be incompatible with the AVR Programmer drivers. I located the prior version of usbser.sys (7/13/2009), and
re-installed that, and the problem went away.

Request to Pololu: Please take a look at this incompatibility.


Thank you for solving the problem and telling us the answer!

We will definitely look in to this.



I tried to reproduce this problem on my Windows 7/x64 laptop. Before I installed Windows 7 Service Pack 1, the system had usbser.sys version 6.1.7600.16385 (7/13/2009, 32768 bytes). After I installed Windows 7 Service Pack 1, the system had usbser.sys version 6.1.7601.17514 (11/20/2010, also 32768 bytes).

For me, the Pololu USB AVR Programmer worked fine with the later version: there were no errors in the Device Manager and I was able to do a loopback test on the TTL Serial port. I did not try the Programming Port.

What version numbers and file sizes were the two usbser.sys versions you encountered?


11/20/2010 05:43 AM 32,768 usbser.sys
07/13/2009 07:06 PM 32,768 usbser.sys

Strange. Maybe I am mistaken, and there is something else at play.

11/20/2010 05:43 AM 32,768 usbser.sys Version 6.1.7601.17514
07/13/2009 07:06 PM 32,768 usbser.sys Vesion 6.1.7600.16385