Avr programmer update firmware problem

Hi everybody

I am very new programming the pololu 3pi and I try to programing it using the avr programmer but I found that I need to update the firmware, I did it following the instruction in the manual, but know my computer cannot detect it ( I am using windows 7).

When I updated the firmware at the end I remember that both led were on (yellow and red) and I disconnect it as the manual said. Then my computer remain detecting the Pololu pgm03a Bootloader, so I think may be there is something that it is open so I reboot my computer and after that my computer cannot detect the avr programmer.

Is there anything that I can do, or I need to buy a new one?

By the way, all the leds are off

Thank you very much


Hello, rozzgg.

I’m sorry you are having trouble with your programmer.

If you haven’t yet, you should just try unplugging it from your computer and everything else and plugging it back in.

If that doesn’t solve the problem, then I think the firmware upgrade failed and you have bad firmware on there now. I’m not sure how it failed but I’m hopeful that if you try it a second time it will work and you’ll be able to program your 3pi. Please see the “Upgrading Firmwre” section of the Pololu USB AVR Programmer’s User’s Guide for instructions on how to get your programmer into bootloader mode even if it has corrupt firmware.


Hello David

Thank you very much for your advice, I will try It and I hope that make my programmer work :smiley:.

hi david,

i also experience the same problem as rozzgg…after upgrading the firware and replugging it, all the leds are off…i have tried to reupgrade it for a few times as per avr pololu user’s guide but still, the same problem occur…wat shud i do?

Hello. I am sorry you are having trouble with your programmer. Did you disconnect the programmer from everything? What did you use to short the bootloader pads together? Are you sure it is conductive and making contact with both pads?


hi David,

i found the solution…keep on reupgrading it n after a few try, it works! tq so much for your concern :wink:

now i get a new problem…i successfully program a few code to test the led and it works and blinking…but when i tried editing the code by changing the port to PD5 and PD6 to test the right motor, suddenly it cant program anymore and pop out these error

An error occured while executing command with ID 0x14. Timed out waiting for a response. Protocol state at time of timeout was ‘Get Data’.

what does it mean?

I am not familiar with this error message you are getting from your programming software. What programming software are you using? What is the version number of the software? What are the exact steps you are taking to generate that error? A screenshot would help.

Could you please open the Pololu AVR Programmer Configuration Utility (from your start menu) and tell me what your ISP frequency is set to?

Sometimes if an unusual error starts happening it can help to just unplug the programmer from everything, reboot the computer, and then try again. Please try that.