AVR programmer only works occasionally

I am on windows 7 64 bit, I am using AVR Studio 4 and an Axon 2 microcontroller.

I have an AVR programmer and I’ve followed the instructions to install it, and moved things around to be on com ports less than 10, and on the first day it worked fine.

Sometimes, when I plug the programmer in at the start of the day it works. Othertimes, the LED by the USB point flashes green, device manager says “device cannot be started (code 10)” and nothing I do will make AVR studio connect to the programmer. On days when it does work, it will usually stop working after a few uses, or if I unplug it. Once it has stopped it almost never starts again. I’ve tried rebooting, changing USB port, turning on and off the Axon2 … nothing brings it back. Sometimes it will refuse to work for a couple of days and then, for no reason I can determine, it will work fine again the next.

I’m pretty sure I must have got most things right, since it would never work if I hadn’t.
I’m pretty sure AVR studio has nothing to do with it, since it doesn’t need to be running for me to tell if I’m going to have a good day or not - I can tell from the lights as soon as it is plugged in to the USB.

As an aside, the instructions say to use AVRISPv2 and there is no such device listed by AVR studio - I’ve found AVRISP doesn’t work, but connecting as STK500 (on days when the green light isn’t flashing) does work. I don’t know if this is a symptom of the same thing.

Any suggestions would be welcome - I’m starting to wonder if it has a loose connection!

Yesterday I completely shut down, waited, and restarted. Didn’t fix it. This morning it is working. Maybe it just needs a good nights sleep?
Anyway, in its working state, the device manager shows this:

Edit: While I was typing this post the computer went “beep borp”, the device went into “not working” mode, and the three valid entries from device manager dissapeared.

Looks like the programmer came with a dodgy USB cable. Wiggling around the programmer end of it makes it register and unregister with the PC. Replaced cable. Working now.

Gods, I’ve spent days thinking this was my fault :frowning:


I’m very sorry that you received a bad cable (and that it caused you so much trouble)! If you email us about this directly, we would be happy to send you a replacement cable.

- Ryan