AVR programmer on XP 64bit


I am having problems with the AVR programmer (PGM03A) on XP 64 bit. “Pololu USB AVR programmer” and “Pololu USB AVR programmer TTL Serial Port” do not install properly. Also, if I run pgm03a.config.exe, the program reports error saying no programmer detected.

I’ve updated OS to the latest version. Any suggestions?



Hello, qiangbo.

In your device manager, the Programming Port (COM3) appears to be successfully installed. The pgm03a_config.exe won’t work, but you might still be able to use AVR Studio or avrdude to talk to the programmer on COM3 and program AVRs. Have you tried using AVR Studio or avrdude?

If you can successfully program AVRs with your programmer and that’s all you want to do, then we can just leave this issue alone. If you want the option to use the bonus features of the programmer, then I’ll help you troubleshoot the issue. Let me know.


Thanks. I actually want to mainly use it as programmer. But I am also interested in other functions as well. Is there a work around?

There are various things we can try.

Please double check to make sure that you have Windows XP Service Pack 3 (SP3).

In the Device Manager, could you please right click on the “Pololu USB AVR Programmer TTL Port” and tell me what it says in the Device Status box? And please do the same for the “Pololu USB AVR Programmer”.

Try unplugging the programmer from USB and plugging it back in. Does that change anything?

Please try this Manual Driver Installation Procedure on the TTL Port:

  1. Right click on “Pololu USB AVR Programmer TTL Port” and select “Update Driver Software…”.
  2. Select “Browse my computer for driver software…”
  3. Select the folder that contains the drivers you downloaded for the programmer. This folder should have a file in it named “pololu_usb_to_serial.inf”.
  4. Click “Next”.

Windows should try to update the driver software. Do you see any error messages at this point? If so, please tell us the exact error message.

Also, please try this manual driver installation procedure on the “Pololu USB AVR Programmer” entry and tell us the results.


Hi David,

In fact, there is no SP3 yet for XP 64 bit.

I tried the manual driver installation. After the installation, it reports “This Device cannot start (Code 10)”.

The properties of two devices are shown in the attached images.

Thanks a lot.


Thanks for the screenshots. However, it looks like you didn’t post a screenshot of the “General” tab for the “Pololu USB AVR Programmer” above. What do you see in that tab?

Oh, I did not know that! Please read this paragraph from the programmer’s user’s guide in the section about installing Windows drivers:

The “The device cannot start. (Code 10)” is the error that occurs when the computer has an older versions of usbser.sys that does not support composite devices like the Pololu USB AVR Programmer.

What version of usbser.sys is currently on your computer? Can you try installing the hotfix mentioned above to upgrade usbser.sys? It is available here:


Sorry, I missed it.

I tried to install the hot fix but an error pops up saying “the hotfix is for a different hardware platform”.

I find usbser.sys in folder “C:\WINDOWS\system32\drivers” and its version is 5.2.3790.1830.



Sorry for the inconvenience. I have looked in to this and unfortunately I can not find any update from Microsoft that will allow you to download a version of usbser.sys for Windows XP 64-bit that is later than the one you already have. Microsoft has released at least 5 hotfixes for usbser.sys over the past decade but none of them apply to your OS. Therefore, I don’t think we will be able to get the bonus features of the programmer working for you, but you should at least be able to program AVRs with it. Have you tried programming an AVR yet? If it doesn’t work, there is an alternate firmware we have that should make it work.



Thank you for investigating the problem. XP 64 is not a very popular OS nor it is a good one. I am actually not surprised that some features don’t work on it.

I tried the programming function this morning. It seems to work just fine. I am happy at least that part works.

Thanks for your time.