Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

AVR programmer - Not installing anything

So I installed the AVR programmer v2.msi file a while back and everything worked perfectly fine although I had to manually setup the ports in device manager as they wouldn’t load. I’ve left it alone for 2 weeks as I’ve had other plans pile up and finally found some time to go back to it.

1st thing I do is load is connect the AVR programmer v2.1 to the micro B to USB A cable and plug it into my computer USB port, load up the config utility and it tells me that the board isn’t connected.

So I check my device manager and notice that both the ports & the USB controller for the AVR programmer are greyed out (only viewable via viewing hidden devices), I went through all the options in the troubleshoot guide, checked against green LED which is on but blinking slowly which indicates that the drivers are incorrectly installed (how is that possible if they were installed and working 2 weeks ago, I don’t know?) even rerunning the .msi installer to repair, uninstall/restart/reinstall, nothing works.

I then decided to uninstall the avr programmer using the .msi file and manually remove the ports and usb controller that remained behind.

Restarted computer, and then reinstalled the avr programmer using the .msi file, problem is nothing is showing up in device manager for the usb controller or the ports.

What am I missing and what’s going on here?

Hello.

Have you tried using your programmer with different USB ports and USB cables, ideally ones that you already know to work with other USB devices? If you have another computer you can test this out with, that would also be good to try.

With the programmer plugged in, can you open the Device Manager, select “View > Devices by Connection”, and post a screenshot showing your USB devices? Please expand anything with “hub” or “USB Composite Device” in the name.

- Patrick