AVR programmer (3172) installation on Windows 10 HELP!

Hi. I’ve been trying to install the AVR programmer on my laptop for about 2 weeks now. No Hair LEFT.

I have tried two different lap tops. One is a Lenovo T460S and the other is a T560S. Both have Windows 10 updated.

The only clue I can find as to why its not working is the comment in the EVENTS tab, 'Device usb/vid…‘requires further installation’. Device Manager/ ports com and LPT/ pololu USB AVR programmer V2.1 …Com 4.

The installation has gone on to install ‘snap-in in the console’ for both the programs. The requires further installation message doesnt go away.

I have restarted the computer dozens of times.



It looks like the drivers for the programmer are installed correctly; the Windows Device Manager screenshots you posted look normal. Can you tell me more about how you are trying to use the programmer and what is not working?

- Patrick

Hi Patrick. Thank you for the reply.

Im running Arduino IDE 2.1.0…and trying to upload the Blink example to a Pro Mini. Unmodified, Stock code.
See attached Capture005.jpg to see the error messages. Programmer isn’t responding.

So…I think I am communicating with the programmer as its able to report the AVR board info. But…the show stops there.

Thanks for your help in advance…


Can you run the Pololu USB AVR Programmmer v2 Configuration Utility (that program should have installed at the same time you installed the drivers) and take a screen shot of it while the programmer is connected? Can you also post some pictures of your physical setup that show the connections between your programmer and Pro Mini board?

- Patrick

Sure,here you go.

Thanks for your help…

Could you change the “VCC output” setting in the configuration utility to “Enabled” and the “Line B function” setting to “DTR (output)” instead of “DTR reset (output),” then try uploading again?

- Patrick


capture008 shows the error msg received when i made your exact change to config,
capture009 shows the complete setup.
capture010 shows the programmer fail message.

I hope you have more ideas…


Can you confirm that you are using a 3.3V version of the Pro Mini? That should be marked on the bottom side of the board. If you actually have a 5V board, could you try setting the programmer’s regulator mode accordingly?

Also, this may seem silly, but just to be safe, are your wires are actually plugged all the way into the headers when you try to program the board? Your picture in an earlier post seems to show many of the wires not plugged in all the way. Can you post a picture of the bottom side of your Pro Mini so I can double check the soldering on the FTDI header pins?

- Patrick

The connectors pulled off a bit to take some of the earlier photos you asked for. They are seated all the way…tripled checked a dozen dozen times.

The board is indeed a 3.3V board. Please find attached photo that shows the marking as such and the serial connections.

Your connections look okay. It is unfortunate that the manufacturer of your board did not actually mark the bottom of it to visibly indicate which version it is. So, if you have not already, I suggest verifying that detail by disconnecting it from your programmer, powering it through the RAW pin (which is supposed to support 3.4 to 12V), and checking the voltage on the VCC pin with a multimeter.

Have you ever successfully programmed this Pro Mini clone with either your Pololu programmer or some other setup, and do you know if there is a bootloader installed in the Pro Mini’s flash? Do you have any other AVR microcontroller boards (like another Arduino) that you know to be working that you could test your Pololu programmer with?

- Patrick

I have not tried powering it through the RAW input. I will do that later today.

I’ve not successfully programmed this board. I did have one instance where I had changed the blink rate in the blink program to a very fast rate…and after attempting to program it…the board did blink at the fast rate. I was playing with the reset button. This was with the pololu unit.

Thanks again for your help. Back after a bit…