Atmel studio does not see proper A-STAR micro when creating from Arduino project

Subject: A-STAR ATMEGA328PB, 5V, 16MHz
Board works fine with program in Arduino IDE (1.8).

When you create a project from the Arduino program in Atmel studio 7, it thinks the arduino version it
is building from has a 32u4 microcontroller…and so the ISP (ICE) does not recognize the chip.
I have tried reselecting the atmega328pb in Atmel studio, but the ISP is still looking for the 32u4 chip.

Any thoughts?


Can you provide more details on the issue (e.g. screenshots of your project’s configuration, settings, Device Programming window, a copy of any error messages you get or your project)? What happens when you try to read the signature from the Device Programming window?

- Amanda

It looks like the Atmel Studio does not see the A-Star board on the list of possibilities.
See attached screen shots of both the Arduino IDE end and the Atmel Studio side.

Also, on one computer I installed the Pololu board with the Arduino board manager update.
On a different computer, I did a manual installation into the sketch folder.
In both cases, the Arduino IDE functions with the Pololu board. In both cases the Atmel studio does not seem to “see” the board as an option.


Hi, Randy.

We do not have an A-Star board add-on for Atmel Studio 7, which sounds like that is what you are expecting. However, Atmel Studo 7 does support ATmega328PB. We tried loading the Arduino’s Blink sketch onto an A-Star 328PB Micro through Atmel Studio 7 and did not have any issues. You can try selecting the Arduino Uno board from the Board drop-down list in the “Create C++ project from Arduino sketch” window, then change the project’s device to ATmega328PB under Project->[sketch name] Properties->Device and see if that fixes the problem.

-\ Amanda

Thanks for the reply,
Yes, I can load an Arduino program to the a-star board via Studio7 and ISP.
As for the "import sketch route, I have tried the idea of selecting the UNO board, then changing the chip type to atmega328PB,
but if you use a function unique to the atmega328PB, i.e., Serial1…
then the compiler generates errors…does not recognize the 2nd serial function which does work when programmed in both the
Arduino IDE and the Studio7 IDE.

Thank you for your input.