AStar32U4 Robot Controller LV Bootloader issue

Setup: A-Star 32U4 Robot Controller LV. Linux. avr-gcc command line upload.

Behavior: Double press reset and yellow led goes into slow fade to indicate bootloader mode, but then within a second, the other led’s start flashing as if a program is being uploaded, even though at the time there was not an active avrdude command to upload. This is new behavior relative to how it was behaving last week.

Troubleshooting Efforts:

  • Tried the same board on a different laptop (MacOS). No problem. Able to upload new program to the board.
  • Tried a different board on the Linux laptop. Same problem.
  • Tried different cables on the Linux laptop. Same problem.
  • Tried different USB ports on the Linux laptop. Same problem.
  • Rebooted the laptop. Same problem.

I have worked on these boards for several years with many students, and I have never seen this behavior before. Any thoughts?

Hello. I am sorry you are having trouble with the A-Star 32U4 Robot Controller LV.

Some Linux systems include a program named ModemManager that automatically connects to most USB serial ports and sends commands to them to determine if they are modems. If you have not done so already, please copy the a-star.rules file that we provide to the /etc/udev/rules.d directory on your system. You can find the file here:

Please let me know if this does not solve the problem or you have any additional questions.


That fixed it. Thank you!!
Sorry that I missed it in the documentation.