Arduino UNO + Pololu USB AVR Programmer : issues

I want to burn the bootloader in a blank Atmega328. I use the Pololu programmer, connecting the ICSP plug directly to Arduino, battery-powered.

I adjusted the two configuration files in this way (I’m under Windows XP SP3):

##Add this to the top of the boards.txt file.

##Add this to the bottom of the programmers.txt file. ISP v2

I open the Arduino software, and select:

Arduino UNO
com port -> Pololu COM port (there are 2)
Programmer -> AVR ISP v2

I get only errors. I tried using both the COM (12 and 13), I tried to use Boarduino instead of Arduino, but I get always the same error:

Than I changeg COM numbers to 5 and 6 in order to use the programmer under AVR STUDIO, but it cant recognizes the programmer…

Thanks you!

I think you should close the Arduino IDE and just try using AVRDUDE + Pololu USB AVR Programmer to flash the bootloader on to the Arduino.

First of all, have you located the HEX file for the bootloader that you want to burn on to your ATmega328?

Secondly, have you determined what COM port your programmer is on? Please unplug your programmer, plug it back in, and then look your Device Manager and tell me all of the entries you see under “Ports (COM & LPT)”. The one that is labeled “Pololu USB AVR Programmer Programming Port” is the COM port you should be using

Please try to burn the bootloader by opening a Command Prompt and typing something like

avrdude -p m328p -P COM2 -c avrispv2 -e -U flash:w:bootloader.hex

You should replace COM2 with the name of programming port as shown in your Device Manager and replace “bootloader.hex” with the name/path of the bootloader HEX file that you want to burn.

If that does not work, please post the command you ran and the entire output of avrdude here. If the red LED on the programmer turns on then try running the Pololu USB AVR Configuration Utility (which is included with the drivers) to find out what the error is, and use that same program to tell us what ISP frequency the programmer is configured to use.


I’ll try!

I don’t have the file, i’ll find it.

Yes, now it is COM n° 5. If I unplug/plug the programmer i find “Pololu USB…” at COM port n°5

In any case, the LEDs appear to be correct: the green is fixed, and the yellow flashes (red off) when I connect the ISP connector to Arduino (battery powered).

It is strange that AVR Studio does not recognize the controller. I’ll try with AVRDUDE

Thanks, thanks, thanks!!!

Always error:

Okay. Could you also try running avrdude with a different -P argument? Try the same command you tried before, but replace “-P COM5” with “-P \.\USBSER000”. Please also try “-P \.\USBSER001” and “\.\USBSER002”.

Also, if you haven’t done so recently, try unplugging your programmer and rebooting your computer.


Both first, and after reboot:

I’m now trying to use TTL serial port (6) using putty, but I receive “Error writing to serial device”.

Now I have installed the programmer in another WIN XP SP3:

what do you think??


You can see from the error message that avrdude cannot find the hex file you have specified. Are you sure the file path is correct?

- Ben

May be wrong, but after that I tryed with AVRDUDE, I tryed with Arduino
software, and I have written the bootloader correctly!!

But, why in the first PC I get error?? Is as the com ports are blocked!

I’m glad you got the bootloader loaded, but I’d like to figure out what went wrong with the programmer.

Please let me know: Does your Arduino UNO’s USB connection / bootloader work on the same computer where our programmer didn’t work?

What version of usbser.sys is on the computer where the programmer didn’t work? You can check what version of this driver you have by looking in the “Details” tab of the “Properties” window for C:\Windows\System32\drivers\usbser.sys.

Could you connect your programmer to the computer where it didn’t work and look carefully in the Device Manager in the Ports (COM & LPT) list to see if there is anything wrong with the programmer’s drivers? Try double clicking on them and tell me what the “Device Status” box says.


Yes, I can use Arduino without problems!!

version 5.1.2600.5512 (xpsp.080413-2108)

It seems all ok…

I noted one thing, in the Device Manager, under “COM and LTP”, I can see only hardware phisically connected to my pc. And this is right. When I use Arduino, or Hyper Terminal, I can see another COM port (number 3), that is not listed in Device Manager / COM and LTP.

It’s strange!!

Uploaded with