Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Arduino Compile (Selected board depends on 'arduino' core)


#1

I have a Zumo 32U4. I would like to compile some code to it. I followed the online instructions for 'Blinky" located here:
pololu.com/docs/0J63/5.2

When I get to step 7 and try to verify or compile, I get the error:

[quote]
Arduino: 1.6.5 (Windows 7), TD: 1.25, Board: “Pololu A-Star 32U4”

Selected board depends on ‘arduino’ core (not installed).

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.[/quote]

The ‘Pololu A-Star 32U4’ is selected along with the correct COM port.

Any ideas?


#2

Hello.

From the error message you are getting, I suspect that the A-Star drivers are not installed correctly. What is the full file path of your “Hardware” folder containing the “pololu” folder from the downloaded “add-on” folder? Can you enable verbose output in the Arduino IDE and post a screenshot of it here? You can turn on verbose output by selecting File->Preferences in the IDE, and then checking the “compilation” and “upload” boxes next to "Show verbose output during: ".

We have heard of others having trouble with using Arduino 1.6.5, but we are not sure if that is causing the problem. Can you try using a different version of the Arduino IDE (e.g. 1.6.4 or 1.6.6) to see if the issue goes away?

- Amanda


#3

Hi @AmandaS,

I’m using a new notebook with Manjaro Linux and I got the same message that @highwayman got. I enabled verbose output and the message is:

Arduino: 1.8.3 (Linux), Board: “Pololu A-Star 32U4”

Error compiling for board Pololu A-Star 32U4.

The current selected board needs the core ‘arduino:arduino’ that is not installed.
/usr/share/arduino/arduino-builder -dump-prefs -logger=machine -hardware /usr/share/arduino/hardware -hardware /home/ce_roland/.arduino15/packages -tools /usr/share/arduino/tools-builder -tools /home/ce_roland/.arduino15/packages -libraries /home/ce_roland/Arduino/libraries -fqbn=pololu-a-star:avr:a-star32U4 -vid-pid=0X1FFB_0X2300 -ide-version=10803 -build-path /tmp/arduino_build_978425 -warnings=default -build-cache /tmp/arduino_cache_751370 -prefs=build.warn_data_percentage=75 -verbose /home/ce_roland/Arduino/libraries/zumo-32u4-arduino-library-master/examples/Demo/Demo.ino

Selected board depends on ‘arduino’ core (not installed).

Error compiling for board Pololu A-Star 32U4.
The current selected board needs the core ‘arduino:ardino’ that is not installed.
The current selected board needs the core ‘arduino:ardino’ that is not installed.

Can you help me to solve this?


#4

Hello.

Thank you for providing detailed information. How did you install the Arduino IDE? I tried replicating your issue by downloading Arduino 1.8.3 from the official Arduino website for Linux, but I was able to compile the Zumo32U4’s Demo sketch without any errors.

Also, I noticed there are typos in the last two lines of your Arduino IDE’s output. Is that your typo, or is that actually from your Arduino IDE?

- Amanda


#5

Hello, I’m also experiencing the same issue.

When I load the Arduino IDE with Board: Pololu A-Star 32U4 selected, I see:

The current selected board needs the core 'arduino:arduino' that is not installed.

I installed the board manually via these instructions.

When verifying the initial empty sketch, I see:

Arduino: 1.8.8 (Linux), Board: “Pololu A-Star 32U4”

The current selected board needs the core 'arduino:arduino' that is not installed.
/usr/share/arduino/arduino-builder -dump-prefs -logger=machine -hardware /usr/share/arduino/hardware -hardware /home/ravi/Arduino/hardware -tools /usr/share/arduino/tools-builder -libraries /home/ravi/Arduino/libraries -fqbn=pololu:avr:a-star32U4 -ide-version=10808 -build-path /tmp/arduino_build_299010 -warnings=none -build-cache /tmp/arduino_cache_842714 -prefs=build.warn_data_percentage=75 -verbose /tmp/untitled689103723.tmp/sketch_feb05a/sketch_feb05a.ino

Selected board depends on 'arduino' core (not installed).

Error compiling for board Pololu A-Star 32U4.

I installed the IDE via:

pacman -S arduino arduino-avr-core

What is the next thing to check for?


#6

Hello.

I noticed you posted this question, and your solution to it, on the Arduino Stack Exchange forum. I am glad you were able to resolve it. For anyone else running into this issue, the solution presented is:

I needed to install the driver for: Arduino AVR Boards. Under Tools -> Board -> Board Manager

-Tony


#7

Could you please add this to Troubleshoting, @TonyP?


#8

I’m not exactly sure what has changed on my system but I have been programming the 3pi robot (ATmega328P) and all was fine a few months ago. Now I get this message but I don’t recall altering anything (didn’t upgrade Arduino IDE, I don’t think I did but I may have updated libraries but that shouldn’t affect this even if I did)

I’ve checked the drivers under Tools --> Board --> Board Manager and I do have the latest Arduino AVR Boards driver installed.

I’m on Mac, I’m not having this issue on Linux. Any thoughts?


#9

Just as a follow up, I’ve tried falling back as far as 1.8.6 (current version is 1.8.9) with no luck. I also tried dropping the AVR Driver to a previous version and reinstalling the latest, with no success.


#10

Still working at this. I tried changing build.core to simply arduino rather than arduino:arduino and now it doesn’t complain about needing arduino:arduino cores but it still fails on build.

Either changing build.core is causing the failure or it has exposed the underlying cause. I got the following error message which I did see before when it was complaining about arduino:arduino cores but didn’t think much of it.

I wonder if the code in this repo changed and this is why it all of the sudden caused a problem on my Mac even though, as mentioned, I didn’t change anything.

panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x10 pc=0x1190c3c]

goroutine 1 [running]:
github.com/arduino/arduino-builder.(*SetupBuildProperties).Run(0x1860e50, 0xc420051000, 0x1860e50, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/setup_build_properties.go:98 +0x11bc
github.com/arduino/arduino-builder.(*ContainerSetupHardwareToolsLibsSketchAndProps).Run(0x1860e50, 0xc420051000, 0x1860e50, 0x0)
	/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/container_setup.go:63 +0x41d
github.com/arduino/arduino-builder.runCommands(0xc420051000, 0xc420061da0, 0x3, 0x3, 0xc420061d01, 0x10c0e95, 0xc42001f790)
	/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:207 +0xe5
github.com/arduino/arduino-builder.(*ParseHardwareAndDumpBuildProperties).Run(0xc420061e00, 0xc420051000, 0x66, 0x7ffeefbffcbb)
	/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:195 +0xee
github.com/arduino/arduino-builder.RunParseHardwareAndDumpBuildProperties(0xc420051000, 0x66, 0x7ffeefbffcbb)
	/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:228 +0x35
main.main()
	/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/arduino-builder/main.go:396 +0x96a
/Applications/Arduino.app/Contents/Java/arduino-builder returned 2

So it appears to be a segfault from trying to access an invalid memory location… but again, this might just be self induced by changing build.core from arduino:arduino to arduino

This is not really in my wheelhouse but I’ll keep trying until someone more intimate with this can help out.

EDIT:
(due to restrictions I can’t post more than 3 replies in a row :man_shrugging: so I’m editing my last post to post the solution)

Okay, I figured out my problem. I’m not sure why this was complaining since I hadn’t changed anything but it appears the folder structure is not what the IDE is looking for. I downloaded the zip (same as cloning the repo) and placed it in the hardware folder as is.

To get this to work I had to create the structure of hardware–>libpololu–>avr and place the contents here… but that’s not all. This doesn’t allow the IDE to find the boards file so I had to move the contents of the arduino folder (currently hardware–>libpololu–>avr–>arduino) where the boards.txt file was and place the files directly in the hardware–>libpololu–>avr folder.

I figured this out by looking at the structure of another set of boards that require manual installation whose structure was slightly different than that of pololus.

P.S. I did change the build.core back to arduino:arduino so don’t mess with that, the only thing I needed to do was restructure the directories.


#11

Hello.

I am glad to hear that you were able to figure it out.

For anyone trying to program a 3pi from the Arduino environment, you should follow the instructions in the “Programming Orangutans and the 3pi Robot from the Arduino Environment” guide. The guide describes how to configure the Arduino IDE so that it programs your 3pi robot using the correct settings and will result in you having the directory structure described by ribbs2521.

-Tony