AltIMU-10 v4 not displaying anything on serial monitor

Hi I just bought an AltIMU-10 v4 sensor and tried running the example programs in the LSP, LSM303, & L3G arduino libraries on an arduino uno r3. However, after checking the wiring, soldering, etc. many times, the serial monitor of the arduino IDE still does not output anything, not even an error. But if nothing is connected then an error message will show. Does anyone know what is wrong with my sensor? The arduino uno I’m using is working fine for other things.


I am sorry you are having problems using your AltIMU-10 v4. Could you tell me more about your setup? Are you connecting the AltIMU-10 directly to the SCL and SDA pins on the Uno? Could you send pictures of your entire setup and close-ups of both sides of the AltIMU-10? Could you also send screenshots of the Arduino IDE?

- Jeremy

Yes I connected the IMU directly to the SCL and SDA pins of the Uno. Here are some photos:

Here are more photos:


Thank you for the pictures. The connections between the AltIMU-10 and your Arduino look correct; however, the soldering of the pins on the AltIMU-10 look like they might not be making good connections. Could you try retouching the pins with a soldering iron to make sure the pins make good connections with the board? If you still have problems communicating with the board after retouching the pins and have access to a Windows computer, could you try programming the Arduino and running the Serial Monitor on the Windows computer to see if the problem is with the Mac?

- Jeremy

Hi thanks for the reply. I tried retouching the pins and tried to test for output current through Vdd and there is current flowing. I tried both windows and Mac. But still don’t work. Could it be static that killed it?

It is possible for something like an ESD zap to damage the board. From your description, it does sound like the board is damaged. If you contact us directly at with your order information and a reference to this forum post, we might be able to help you with a discount on a replacement.

- Jeremy

I have the same issue with Minium 9 v2. I tested it on two different Adrduino Uno’s, tested 2 different Minimu boards, both on Win and Mac. The funny thing is only serial won’t work, the sensor feeds the program with data.
The serial feed worked, but then stopped, i thought i made an error in the code, but even AHRS or L3G/LSM 303 library examples won’t work.

Any clues? :question:

i think i got it. Serial crashes when 2 arduinos and imu are connected via i2c. Separated i get the readings.


Connecting two MinIMU-9 v2 sensor boards on the same I2C bus will not work since there is not a way to address them individually. If you need to connect two IMU sensors to the same I2C bus, you might consider upgrading them (or just one) to the MinIMU-9 v3. The MinIMU-9 v3 board has the SA0 pin broken out, which allows you to change the slave address and connect two MinIMUs on the same I2C bus. You can read more about this in the “I2C Communication” section on the MinIMU-9 v3 product page.

- Jeremy

I have the same problem with altimu 10 v4. I soldered pins and now I can’t see anything on the monitor. I am always at near the part and I couldn’t feel any esd. My multimeter is broken and I can’t measure the Vdd voltage. What do you recommend for me? I bought this part from one of the robot hobby sites in Turkey.


I am sorry you are having trouble reading data from your AltIMU-10. Can you tell me more about your setup? What are you using to read the data? How are you supplying power? Can you also post pictures that clearly show your soldering joints and how you are connecting everything?

By the way, electro-static discharges can happen between your body and electronics without you noticing it, so just because you did not feel, see, or hear anything does not mean a static shock did not occur. Do you have reason to believe your board was damaged by ESD?