Aaagh! my 3pi's QTR sensors stopped working!

Your library can’t read the sensors anymore, and i have no idea why - the exact same program worked this morning, and doesn’t work anymore :frowning:

I was using the 3pi-linefollower-pid modified to follow white lines (changed the 2 read_line commands to read_line_white) and use the potentiometer for max speed.

I even tried a brand new copy of the demo program and it still doesn’t work!
I’ve reprogrammed the fuses, reinstalled the whole dev environment…

aaaaagh! Please don’t tell me i’ve got a dodgy mega168 with a timer that doesn’t work…sending this thing back and forth to be fixed is going to cost a bomb (i live in Australia)



OK, this is weird. Sometimes they work, sometimes they don’t.



It appears the IR LEDs on my 3pi are not turning on when they should be, as it works with an external source of IR.

I tried removing the jumper (which is supposed to force them on) but they are still off (digital camera which i have confirmed to not have an IR filter)



Has your 3pi recently crashed into anything or driven over anything rough? It sounds like one of the components on the underside of the board might have been knocked off, and the result is that power is no longer being routed to the IR LEDs. Can you inspect the bottom of the board for missing components (especially near the line sensors)? If you don’t see anything, can you post a somewhat high-resolution picture of the underside of your 3pi?

- Ben

Nope, nothing but a polished cork floor and a couple of desks…

Doesn’t appear to be anything missing, i’ll go take a 10mpix image of its underside…

OK, i’ve uploaded 2 hi-rez pics of the bottom to .

I Just checked with another camera, and the sensors on PC0 and PC1 are spitting out light, but the other 3 are not - as is evidenced by the third photo in the folder.

Any ideas?


Well that looks a little unhappy:

In the other picture, the circled sensor and the one to its left are the two lighting up.


That circled sensor would explain the problem. The solder joints on one side of the sensor might have been weak, and contact with something could have nudged the leads off of the pads. Can you try to gently push it back into position? Once there, you should be able to use a soldering iron to melt the solder on the pads and combine it with some new solder of your own to reestablish the connections between the part and the PCB. Do you feel comfortable doing soldering rework like this?

- Ben

It happened to me as well but I crashed it with maximum speed somewhere.
It’s very easy to put it back if you did soldering before :slight_smile:

How on earth did i not notice that?!

I’ll fix that tonight :slight_smile: - i’m fine with soldering SMD parts that are already tacked down…except QFN stuff but i should be fine with this :slight_smile:



Thanks very much guys! i added a little more solder to all the other sensors too as they looked a bit lacking.


I’m very glad to hear it’s up and running again!

- Ben