a4988 stepper motor driver not giving voltage at the output

First of all, i wanted to tell everyone that i am a mechanical student so don’t know much about electronics.
I started building one project for which i need to use Stepper motors. So i bought Nema 17 stepper motor, Arduino Mega and the stepper motor driver a4988.
So i made the connections like this…
i connected my arduino mega to my laptop via USB cable provided with the board. Then i connected pin 13 of the board to the direction pin of the a4988, pin 12 to the step pin of a4988. Then i connected the reset pin and the sleep pin together, which is in the a4988. Then i connected +5V to the VDD and the respective ground. and then i connected VMOT to +12V and the respective ground. Then i connected my bipolar stepper motor, which has 4 wires to the ports 1a 1b 2a and 2b. Then i copied the program for one of the sites and uploaded that program to the arduino mega. It uploaded succesfully. But the motor was not moving.

I tried many-many different connections but was not able to rotate the shaft of the motor. So finally i started checking each component.
I used one of the examples of the arduino, which i uploaded to it and it was working fine. Then i checked the Nema 17 motor by checking the resistance between the 2 wire which i got to be around 4ohms for both the coils. then i connected a 9v battery to one of the coils and tried turning the motor shaft but it was harder to move in comparison to when the battery was not connected. i did the same with the other coil. this proves that the coils are ok and the circuit is complete and the coils are producing magnetic field. this proves that the stepper motor is fine.

then i checked the a4988 stepper motor. i checked the voltage between the vdd and gnd, it was 5v. then between vmot and the gnd, it was 12v. then i checked the voltage difference between direction and step(just like that).
after that the main problem came out. I checked the voltage between the 2 of the output pins and it was zero. then the other two output pins, which was again zero. i checked whether i was checking the voltage between the 2 wires of the same coil, and it was right.

Now i think that stepper motor driver a4988 is somewhat defective. It is not giving any output to the output pins which are connected to the motor.

Please help me with this problem. I tried many different programs that i found on the internet, but none of them are working. the only reason that i can think of is that the a4988 is defective. If you think it is defective then please reply fast so that i can return it back(i bought it from ebay.in).

Thanks in advance.


Are you using a Pololu stepper motor driver board? If so, which Pololu A4988 stepper motor driver carrier are you using? What are you using for your motor power supply? What are the voltage and current ratings for your stepper motor? What did you set the current limit on your stepper motor driver to? Could you post pictures of your setup?

- Grant

i think that i am using pololu driver board, but i am not sure. i bought it from ebay.in.
well i don’t know about driver carrier ( i don’t know what it is)
i am using a smps for power supply. i used the +12v power supply to give power to vmot, and +5v power supply to give power to the driver board.
voltage rating is of 5v and current rating is 1.2amp. I am supplying +12v to the vmot pin provided in the driver.
i rotated the potentiometer provided in the driver, but it didn’t do anything.
here are the pictures of the connection.

here are the remaining images.

We cannot help you trouble shoot that board since it is not one of ours and we do not know how it is configured. You might try the RepRap forums for additional help, since it looks like that is one of their boards.

From a quick look at your pictures, there are a few things in your setup that might be causing problems. It looks like your header pins are not soldered in. You should solder them in to ensure proper connections. It also looks like you are using a power supply intended for computers. Most power supplies for computers require a signal from a the computer to turn on. Have you measured the voltage to make sure you are getting power from your power supply? I also noticed you do not have a common ground between your Arduino Mega and stepper motor driver; you should probably add one.

- Grant

yes, i am using a smps that is used in computers, but i did the necessary connections for supplying voltage. as i said before i checked the voltages between the vdd and gnd, and vmot and gnd, which aare +5v and +12v respectively.
well i recently found out that the driver that i was using was actually impaired, so now i have got my money back and will buy the pololu one and keep this post updated.

Sorry for replying this late but i finally got the whole thing working(the driver was faulty). My project is done.
I just want to thank everyone for your help and support.

Here’s the link for the video.

Awesome project! I am glad you got it working. Did switching to our stepper motor driver carriers fix the issue?

- Grant