A4988 no output on A1 ,A2, B1 and B2 pins

Hi everyone,

I am new in here and hope to get a little help.

I am experiencing som issues getting my stepper motor to turn.

When I get my A4988 driver up and running, and send it a step signal, nothing happens. I have added LED diodes to confirm, that I am actualy sending the step signal correctly.

Also the chip is not getting warm at all (it is rather cold). Could it be that it is not even up and running?

The wiring can be seen here:

The red LED confirms 5v power. The yellow LED confirms that I send a step signal correctly.

The capacitor is 100 myFarad. The green and brown wires in the right is my 12v power supply. This power rail is 5v.

How can it be that I do not get any output on my stepper motor pins?

I have a drive tester

for testing that my driver is actually working.

What am I doing wrong?

Kind regards

I found my solution.

The LEDs simply took out to much voltage, to run the A4988 driver, so I took them out.

That solved my problem.

Everything is working perfectly now.

Greetings from Denmark.


I am glad you figured out what the problem was. Thank you for letting us know how you solved your issue.

- Amanda